HDU 1517 A Multiplication Game

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

Input

Each line of input contains one integer number n.

Output

For each line of input output one line either

Stan wins.

or

Ollie wins.

assuming that both of them play perfectly.

Sample Input

162
17
34012226
Sample Output
Stan wins.
Ollie wins.
Stan wins.
题意:令p=1,然后每个人每次令p乘于一个范围是[2,9]的数,stan先,直到p>=n时游戏结束,把p操作完后使得p>=n的那个人获胜
思路:可知(n,正无穷)为必败态,因为此时已经达到了条件,他前面操作的那个人已经赢了,然后必败态的前面为必胜态,能达到必败态的都是必胜态,然后推出来必胜态范围是[n/9,n-1],然后往前面推必败态[n/9/2,n/9-1],直到n变为1的时候就结束了,然后根据进行的步数判断一下哪个赢

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<set>
#include<math.h>
#define mod 10007
#define ll long long
using namespace std;
int main()
{
    ll n;
    while(scanf("%lld",&n)!=EOF)
    {
        int flog=1;
        while(n>1)
        {
            if(flog)
            {
                n=ceil(n/9.0);
            }
            else
            {
                n=ceil(n/2.0);
            }
            flog=(flog+1)%2;
        }
        if(!flog)
        {
            printf("Stan wins.\n");
        }
        else
        {
            printf("Ollie wins.\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值