HDU 1297 Children’s Queue 递推

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10392    Accepted Submission(s): 3335

Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
Sample Input
  
  
1 2 3
Sample Output
  
  
1 2 4
/*
HDU 1297 Children’s Queue
男女排列问题
f(n)的合法序列可以有以下几种产生:
f(n-1)+M
f(n-2)+FF ;这两个都是合法的
不合法的 :f(n-4)+MF+FM/+MF+FF 
f(n)=f(n-1)+f(n-2)+f(n-4)

这种递推题完成后 代入最大值要看是否越界 
这里int不行 __int64也不行  要用大数
1 2 4 7 大数打表要用二维数组 
*/

#include<iostream>
using namespace std;

int a[1001][246];
int main(){
    int i,j,n,k,z;
    a[1][1]=1;a[1][0]=1;//长度 
    a[2][1]=2;a[2][0]=1;
    a[3][1]=4;a[3][0]=1;
    a[4][1]=7;a[4][0]=1;
    k=1;
    for(i=5;i<1001;i++)
    {
        for(j=1;j<=k;j++)
            a[i][j]=a[i-1][j]+a[i-2][j]+a[i-4][j];
        z=0;
        for(j=1;j<=k;j++)
        {
            z=z+a[i][j];
            a[i][j]=z%10;
            z/=10;
        }
        while(z)
        {
            k++;
            a[i][k]=z%10;
            z/=10;
        }
        a[i][0]=k;
    }    
//    printf("%d\n",a[1000][0]);==245 先开较大的数组在输出最大的位数 调整 
    while(scanf("%d",&n)!=EOF)
    {
        for(j=a[n][0];j>=1;j--)
            printf("%d",a[n][j]);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值