Children’s Queue(递推)

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12101    Accepted Submission(s): 3953


Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 

Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 

Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 4
 
   题意:有n个位置,男孩女孩排队,要求女孩至少要2个在一起。
 
  思路:设f[n]表示,n个人的情况。情况一、在f[n-1]的情况后面加一个男孩;情况二、在f[n-2]的情况后面加两个女孩;情况三、在f[n-3]最后是男孩(等价于在f[n-4]个个数)的后面加三个女孩;
所以:f[n]=f[n-1]+f[n-2]+f[n-4];由于数据比较大,所以采用大数加法就可以了。
 
转载请注明出处: 寻找&星空の孩子   题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1297
 
 
#include<stdio.h>
#include<string.h>
int f[1005][105];
void init()
{
    memset(f,0,sizeof(f));
    f[0][1]=1;
    f[1][1]=1;
    f[2][1]=2;
    f[3][1]=4;

    for(int i=4;i<=1000;i++)
    {
        int add=0;
        for(int j=1;j<=100;j++)
        {
            f[i][j]=f[i-1][j]+f[i-2][j]+f[i-4][j]+add;
            add=f[i][j]/10000;
            f[i][j]%=10000;
            if(add==0&&f[i][j]==0)break;
        }
    }
}
int main()
{
    int n;
    init();
    while(scanf("%d",&n)!=EOF)
    {
        int k=100;
        while(!f[n][k])k--;
        printf("%d",f[n][k--]);
        for(;k>0;k--)
        {
            printf("%04d",f[n][k]);
        }
        printf("\n");
    }
    return 0;
}

  • 5
    点赞
  • 18
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值