zoj2110 - Tempter of the Bone (DFS + 奇偶性剪枝)

Tempter of the Bone

Time Limit: 2 Seconds                                     Memory Limit: 65536 KB                            

The doggie found a bone in an ancient maze, which fascinated him a lot. However,   when he picked it up, the maze began to shake, and the doggie could feel the   ground sinking. He realized that the bone was a trap, and he tried desperately   to get out of this maze.

  The maze was a rectangle with sizes N by M. There was a door in the maze. At   the beginning, the door was closed and it would open at the T-th second for   a short period of time (less than 1 second). Therefore the doggie had to arrive   at the door on exactly the T-th second. In every second, he could move one block   to one of the upper, lower, left and right neighboring blocks. Once he entered   a block, the ground of this block would start to sink and disappear in the next   second. He could not stay at one block for more than one second, nor could he   move into a visited block. Can the poor doggie survive? Please help him.


Input

  The input consists of multiple test cases. The first line of each test case   contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50),   which denote the sizes of the maze and the time at which the door will open,   respectively. The next N lines give the maze layout, with each line containing   M characters. A character is one of the following:

  'X': a block of wall, which the doggie cannot enter;
  'S': the start point of the doggie;
  'D': the Door; or
  '.': an empty block.

  The input is terminated with three 0's. This test case is not to be processed.


Output

  For each test case, print in one line "YES" if the doggie can survive,   or "NO" otherwise.


Sample Input

  4 4 5
  S.X.
  ..X.
  ..XD
  ....
  3 4 5
  S.X.
  ..X.
  ...D
  0 0 0


  Sample Output


  NO
  YES

                     用dfs不剪枝wa,关于奇偶性剪枝部分直接扒网上讲的

/*********************************
*
*   acm:   zoj-2110
*
*   title: Tempter of the Bone
*
*   time : 2014.11.17
*
*********************************/

//考察深度优先搜索+奇偶性剪枝

/*
剪枝问题:奇偶性剪枝。
易错问题:方向循环的语句里不能用t++, 因为for (i = 0; i < 4; i++) 如果下步是墙壁,此时t增大了,会返回时,t是增大的!
*/

/* *********************** 奇偶剪枝 ********************* */
/*就是把格子按国际象棋的布局涂成黑白两色 然后讨论奇偶性*/
/*
可以把map看成这样:
0 1 0 1 0 1
1 0 1 0 1 0
0 1 0 1 0 1
1 0 1 0 1 0
0 1 0 1 0 1
从为 0 的格子走一步,必然走向为 1 的格子
从为 1 的格子走一步,必然走向为 0 的格子
即:
从 0 走向 1 必然是奇数步
从 0 走向 0 必然是偶数步

所以当遇到从 0 走向 0 但是要求时间是奇数的
或者 从 1 走向 0 但是要求时间是偶数的
都可以直接判断不可达!
*/
/* *********************** 奇偶剪枝end ******************* */

#include <stdio.h>
#include <stdlib.h>
#include <math.h>

#define MAX 50
#define MAXVEX 7

#define TRUE 1
#define FALSE 0

typedef int Boolean;  //布尔类型
Boolean escape;       //是否成功逃脱,escape = TRUE 表示能成功逃脱

char map[MAXVEX][MAXVEX];    //迷宫地图
int dir[4][2] = {{0,-1}, {0,1}, {1,0}, {-1,0}};   //分别表示下,上,右,左 4个方向

int di, dj;   //(di, dj)门的位置

int N, M;  //迷宫的长(高) 和宽
int T;     //迷宫的门在第T秒时刻开启

/*  以下字符具有的含义:
X :墙壁,小狗不能进入;
S :小狗所处的位置
D :迷宫的门
. :空的方格
*/


void DFS(int si, int sj, int t)
{
    int i;
    int temp;

    if (si >= N || si < 0 || sj >= M || sj < 0)
    {
        return ;
    }

    if (si == di && sj == dj && t == T)
    {
        escape = TRUE;
        return ;
    }

    //fabs(si-di) - fabs(sj-dj) 现在所在格子到目标格子的距离
    //T - t 实际还需要的步数
    //如果temp<0 ||temp是奇数,那就不可能到达。
    //解释:如果有路径,那么T - t 与 fabs(si-di) - fabs(sj-dj)的奇偶性必然是一致的,相减必然temp为偶数  参考奇偶性剪枝

    temp = (T - t) - fabs(si-di) - fabs(sj-dj);  //剪枝处理

    if (temp < 0 || temp % 2)
    {
        return;
    }

    for (i = 0; i < 4; i++)   //递归4个方向
    {
        if (map[ si+dir[i][0] ][ sj+dir[i][1] ] != 'X')
        {
            map[ si+dir[i][0] ][ sj+dir[i][1] ] = 'X';
            DFS(si + dir[i][0], sj + dir[i][1], t + 1);  //这里不能用t++, 因为for (i = 0; i < 4; i++) 下步是墙壁,会返回,但此时t增大了。
            map[ si+dir[i][0] ][ sj+dir[i][1] ] = '.';
        }
    }
}

int main()
{
    int i, j;  //变量
    int si, sj;   //小狗的起始位置

    while (scanf("%d%d%d", &N, &M, &T), N && M && T)
    {
        for (i = 0; i < N; i++)
        {
            for (j = 0; j < M; j++)
            {
                scanf(" %c", &map[i][j]);

                if (map[i][j] == 'D')
                {
                    di = i;
                    dj = j;
                }
                else if (map[i][j] == 'S')
                {
                    si = i;
                    sj = j;
                }

            }
        }

        escape = FALSE;   //初始化 小狗不能逃脱的状态

        map[si][sj] = 'X';
        DFS(si, sj, 0);

        if (escape)
        {
            printf("YES\n");
        }
        else
        {
            printf("NO\n");
        }
    }

    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值