poj1562 & zoj1709 - Oil Deposits (DFS)

Oil Deposits
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12926 Accepted: 7063

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

Source

 
          这道题我一次就ac成功 m、n为局部变量,第二次我仅仅将m、n设为全局变量竟然wa! 后来我将map[100][100] 改成map[101][101] ac! 这是why?????
这道题数组开到map[100][100]就够了,局部变量也ac了!不理解T_T
 
 
/*********************************
*
*   acm:   zoj-1709 & poj-1562
*
*   title: Oil Deposits
*
*   time : 2014.11.18
*
*********************************/

//考察深度优先搜索

/*
    分析:
    从网络中某个"@"字符位置开始进行DFS搜素,
    搜索出跟此位置同一块区域的位置,标记已搜过,并油田数量+1
*/

/*
    int m, n 设置成全局变量就出错why???
*/

#include <stdio.h>
#include <stdlib.h>

#define MAXVEX 101

char map[MAXVEX][MAXVEX];   //地图

int dir[8][2] ={{1,0}, {-1,0}, {0,1}, {0, -1}, {1,1}, {-1,-1}, {1,-1}, {-1,1}};  // 方格的八个相邻的方向
int m, n;   //表示行和列

/*
*: 代表没有石油
@: 代表石油
*/


void DFS(int i, int j)  //从(i,j)位置深搜
{
    int k;
    int x, y;
    for (k = 0; k < 8; k++)
    {
        x = i+dir[k][0];
        y = j+dir[k][1];

        if (x < 0 || x >= m || y < 0 || y >= n)
        {
            continue;
        }

        if (map[x][y] == '@')
        {
            map[x][y] = '*';
            DFS(x, y);
        }
    }
}


int main()
{
    int i, j;
    int num;

    while (scanf("%d%d", &m, &n), m)
    {
        num = 0;

        for (i = 0; i < m; i++)
        {
            scanf("%s", map[i]);
        }

        for (i = 0; i < m; i++)
        {
            for (j = 0; j < n; j++)
            {
                if (map[i][j] == '@')
                {
                    map[i][j] = '*';
                    num++;
                    DFS(i, j);
                }
            }
        }

        printf("%d\n", num);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值