UVA 1252 Twenty Questions 状压DP

简单状压DP:
当前状态s如果这个物品有状态a个属性,枚举下一个要猜测的特征k
dp[s][a]=min(dp[s][a],max(dp[s+k][a],dp[s+k][a+k])+1);


4643 - Twenty Questions

Asia - Tokyo - 2009/2010
Consider a closed world and a set of features that are defined for all the objects in the world. Each feature can
be answered with yes" orno”. Using those features, we can identify any object from the rest of the objects
in the world. In other words, each object can be represented as a fixed-length sequence of booleans. Any
object is different from other objects by at least one feature.
You would like to identify an object from others. For this purpose, you can ask a series of questions to
someone who knows what the object is. Every question you can ask is about one of the features. He/she
immediately answers each question with yes" orno” correctly. You can choose the next question after you
get the answer to the previous question.
You kindly pay the answerer 100 yen as a tip for each question. Because you don’t have surplus money, it is
necessary to minimize the number of questions in the worst case. You don’t know what is the correct answer,
but fortunately know all the objects in the world. Therefore, you can plan an optimal strategy before you start
questioning.
The problem you have to solve is: given a set of boolean-encoded objects, minimize the maximum number of
questions by which every object in the set is identifiable.
Input
The input is a sequence of multiple datasets. Each dataset begins with a line which consists of two integers, m
and n: the number of features, and the number of objects, respectively. You can assume 0 < m 11 and 0 <
n 128. It is followed by n lines, each of which corresponds to an object. Each line includes a binary string of
length m which represent the value (yes" orno”) of features. There are no two identical objects.
The end of the input is indicated by a line containing two zeros. There are at most 100 datasets.
Output
For each dataset, minimize the maximum number of questions by which every object is identifiable and
output the result.
Sample Input
8 1
11010101
11 4
00111001100
01001101011
01010000011
01100110001
11 16
01000101111
01011000000
01011111001
01101101001
01110010111
4643 - Twenty Questions 1/301110100111
10000001010
10010001000
10010110100
10100010100
10101010110
10110100010
11001010011
11011001001
11111000111
11111011101
11 12
10000000000
01000000000
00100000000
00010000000
00001000000
00000100000
00000010000
00000001000
00000000100
00000000010
00000000001
00000000000
9 32
001000000
000100000
000010000
000001000
000000100
000000010
000000001
000000000
011000000
010100000
010010000
010001000
010000100
010000010
010000001
010000000
101000000
100100000
100010000
100001000
100000100
100000010
100000001
100000000
111000000
110100000
110010000
110001000
110000100
110000010
110000001
110000000
0 0
Sample Output
0
2
4


/* ***********************************************
Author        :CKboss
Created Time  :2015年02月22日 星期日 14时49分48秒
File Name     :UVA1252.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

const int maxn=3000;

int n,m;
int num[300];
int dp[maxn][maxn];
int cnt[maxn][maxn];

void init()
{
    memset(dp,-1,sizeof(dp));
    memset(cnt,0,sizeof(cnt));
}

void dfs(int s,int a) /// 已经枚举特征s,w具有特征a
{
    if(dp[s][a]!=-1) return ;
    if(cnt[s][a]<=1) 
    {
        dp[s][a]=0; return ;
    }
    for(int i=0;i<m;i++)
    {
        if(s&(1<<i)) continue ;
        int ns=s|(1<<i);
        int na=a|(1<<i);
        dfs(ns,a); dfs(ns,na);
        if(dp[s][a]==-1)
            dp[s][a]=max(dp[ns][a],dp[ns][na])+1;
        else 
            dp[s][a]=min(dp[s][a],max(dp[ns][a],dp[ns][na])+1);
    }
}

int main() {
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

    while(scanf("%d%d",&m,&n)!=EOF)
    {
        if(n==0&&m==0) break;
        init();
        for(int i=0;i<n;i++)
        {
            char temp[20];
            int ans=0;
            scanf("%s",temp);
            for(int j=0;j<m;j++)
                if(temp[j]=='1') ans|=(1<<j);
            num[i]=ans;
        }
        for(int i=0;i<(1<<m);i++)
            for(int j=0;j<n;j++)
                cnt[i][num[j]&i]++;
        dfs(0,0);
        printf("%d\n",dp[0][0]);
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值