UVA 1252 - Twenty Questions(状态压缩DP+记忆化搜索)

Consider a closed world and a set of features that are defined for all the objects in the world. Each feature can be answered with ``yes" or ``no". Using those features, we can identify any object from the rest of the objects in the world. In other words, each object can be represented as a fixed-length sequence of booleans. Any object is different from other objects by at least one feature.

You would like to identify an object from others. For this purpose, you can ask a series of questions to someone who knows what the object is. Every question you can ask is about one of the features. He/she immediately answers each question with ``yes" or ``no" correctly. You can choose the next question after you get the answer to the previous question.

You kindly pay the answerer 100 yen as a tip for each question. Because you don't have surplus money, it is necessary to minimize the number of questions in the worst case. You don't know what is the correct answer, but fortunately know all the objects in the world. Therefore, you can plan an optimal strategy before you start questioning.

The problem you have to solve is: given a set of boolean-encoded objects, minimize the maximum number of questions by which every object in the set is identifiable.

Input 

The input is a sequence of multiple datasets. Each dataset begins with a line which consists of two integers, m and n: the number of features, and the number of objects, respectively. You can assume 0 < m$ \le$11and 0 < n$ \le$128. It is followed by n lines, each of which corresponds to an object. Each line includes a binary string of length m which represent the value (``yes" or ``no") of features. There are no two identical objects.

The end of the input is indicated by a line containing two zeros. There are at most 100 datasets.

Output 

For each dataset, minimize the maximum number of questions by which every object is identifiable and output the result.

Sample Input 

8 1 
11010101 
11 4 
00111001100 
01001101011 
01010000011 
01100110001 
11 16 
01000101111 
01011000000 
01011111001 
01101101001 
01110010111 
01110100111 
10000001010 
10010001000 
10010110100 
10100010100 
10101010110 
10110100010 
11001010011 
11011001001 
11111000111 
11111011101 
11 12 
10000000000 
01000000000 
00100000000 
00010000000 
00001000000 
00000100000 
00000010000 
00000001000 
00000000100 
00000000010 
00000000001 
00000000000 
9 32 
001000000 
000100000 
000010000 
000001000 
000000100 
000000010 
000000001 
000000000 
011000000 
010100000 
010010000 
010001000 
010000100 
010000010 
010000001 
010000000 
101000000 
100100000 
100010000 
100001000 
100000100 
100000010 
100000001 
100000000 
111000000 
110100000 
110010000 
110001000 
110000100 
110000010 
110000001 
110000000 
0 0

Sample Output 

0 
2 
4 
11 
9

题意:这题意实在是很费解啊,每个串代表一个东西,这个东西是01组成的,现在你可以询问一个位置的特征,对于每个东西如果为1回答YES,如果为0回答NO。那么如果你当前无法区分开每个东西,就可以继续问一个特征,现在要求最坏情况下,你需要询问几次的最少次数。

思路:状态压缩DP+记忆化搜索,s1代表当前一共询问的特征的集合,s2答案的集合,计算当前s1&state[i] == s2的东西个数,由于要最坏情况,肯定是越大越好,当<=1的时候,说明已经全部区分开了,所以每次添加一个特征询问时候,回答可能是yes或no,要选其中大的,所以状态转移方程为:

dp[s1][s2] = min(dp[s1][s2], max(DP(s1|(1<<i), s2), DP(s1|(1<<i), s2^(1<<i))) + 1);

代码:

#include <stdio.h>
#include <string.h>
#define INF 0x3f3f3f3f
#define min(a,b) ((a)<(b)?(a):(b))
#define max(a,b) ((a)>(b)?(a):(b))
const int M = 12;
const int N = 130;
const int MAXM = (1<<M);
int m, n, state[N], dp[MAXM][MAXM];

int DP(int s1, int s2) {
	if (dp[s1][s2] != -1) return dp[s1][s2];
	dp[s1][s2] = INF;
	int num = 0, i;
	for (i = 0; i < n; i++) {
		if ((s1&state[i]) == s2)
			num++;
	}
	if (num <= 1)
		return dp[s1][s2] = 0;
	for (i = 0; i < m; i++) {
		if (s1&(1<<i)) continue;
		dp[s1][s2] = min(dp[s1][s2], max(DP(s1|(1<<i), s2), DP(s1|(1<<i), s2^(1<<i))) + 1);
	}
	return dp[s1][s2];
}

int main() {
	while (~scanf("%d%d", &m, &n) && n + m) {
		char str[M];
		for (int i = 0; i < n; i++) {
			scanf("%s", str);
			int s = 0;
			for (int j = 0; str[j]; j++) {
				if (str[j] == '1')
					s = (s|(1<<j));
			}
			state[i] = s;
		}
		memset(dp, -1, sizeof(dp));
		printf("%d\n", DP(0, 0));
	}
	return 0;
}


评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值