[并查集] poj1703 Find them,Catch them


Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 36063 Accepted: 11051

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.


题意:一个城市里有两个帮派,有N名来自两个帮派的帮众,给定两个操作:

D a b 表示第a个帮众和第b个帮众不属于同一个帮派

A a b 询问a和b之间是否属于同一帮派。(是、不是或者未知)


定义一个 2 * N 的并查集,如果 i 表示属于帮派 i ,那么 i + N 属于帮派B,每次输入两个帮众在不同帮派的时候,就合并它们分属于两个帮派的元素。

对于 帮众x和帮众y:

如果并查集中x和y属于同一集合,那么在同一个帮派;

如果并查集中x和y+N属于同一集合,那么在不同帮派;

否则情况未知。


#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define MAX_N 100000 * 2 + 16
using namespace std;
int pre[MAX_N];
int find(const int& x)
{
    if (pre[x] == x)
        return x;
    else
        return pre[x] = find(pre[x]);
}
void unite(int x, int y)
{
    int fx = find(x),fy = find(y);
    if (fx != fy)
        pre[fy] = fx;
}

int main()
{
    int T,N,M,x,y;
    cin >> T;
    while (T--)
    {
        cin >> N >> M;
        for (int i = 0; i < 2*N; i++)
            pre[i] = i;
        char ch;
        getchar();
        while (M--)
        {
            scanf("%c%d%d%*c", &ch, &x, &y);
           if (ch == 'A')
           {
               if (find(x)==find(y))
                   cout<<"In the same gang." <<endl;
               else if (find(x) == find(y+N))
                   cout<<"In different gangs."<<endl;
               else
                   cout<<"Not sure yet."<<endl;
           }
           else
           {
               unite(x, y + N);
               unite(x + N, y);
           }
        }
    }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值