最优比例生成环(dfs判正环或spfa判负环)

http://poj.org/problem?id=3621

Sightseeing Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7649 Accepted: 2567

Description

Farmer John has decided to reward his cows for their hard work by taking them on a tour of the big city! The cows must decide how best to spend their free time.

Fortunately, they have a detailed city map showing the L (2 ≤ L ≤ 1000) major landmarks (conveniently numbered 1.. L) and the P (2 ≤ P ≤ 5000) unidirectional cow paths that join them. Farmer John will drive the cows to a starting landmark of their choice, from which they will walk along the cow paths to a series of other landmarks, ending back at their starting landmark where Farmer John will pick them up and take them back to the farm. Because space in the city is at a premium, the cow paths are very narrow and so travel along each cow path is only allowed in one fixed direction.

While the cows may spend as much time as they like in the city, they do tend to get bored easily. Visiting each new landmark is fun, but walking between them takes time. The cows know the exact fun values Fi (1 ≤ Fi ≤ 1000) for each landmark i.

The cows also know about the cowpaths. Cowpath i connects landmark L1i to L2i (in the direction L1i -> L2i ) and requires time Ti (1 ≤ Ti ≤ 1000) to traverse.

In order to have the best possible day off, the cows want to maximize the average fun value per unit time of their trip. Of course, the landmarks are only fun the first time they are visited; the cows may pass through the landmark more than once, but they do not perceive its fun value again. Furthermore, Farmer John is making the cows visit at least two landmarks, so that they get some exercise during their day off.

Help the cows find the maximum fun value per unit time that they can achieve.

Input

* Line 1: Two space-separated integers: L and P
* Lines 2..L+1: Line i+1 contains a single one integer: Fi
* Lines L+2..L+P+1: Line L+i+1 describes cow path i with three space-separated integers: L1i , L2i , and Ti

Output

* Line 1: A single number given to two decimal places (do not perform explicit rounding), the maximum possible average fun per unit time, or 0 if the cows cannot plan any trip at all in accordance with the above rules.

Sample Input

5 7
30
10
10
5
10
1 2 3
2 3 2
3 4 5
3 5 2
4 5 5
5 1 3
5 2 2

Sample Output

6.00

题意:有n个景点和一些单项道路,到达一个顶点会获得一定的快乐值,经过道路会消耗一定的时间,一个人可以任意选择一个顶点作为开始的地方,然后经过一系列的景点返回原地;每个景点可以经过多次,但是只有经过第一次景点的时候才可以获得欢乐值,并且要旅游至少两个顶点,以保证得到足够的锻炼;问单位时间的欢乐值最大是多少;

分析:该题思路和最优比例生成树有些类似,设第i个点的欢乐值f[i],边权值是w[u][v];

对于一个环比率:r=(f[1]*x1+f[2]*x2+f[3]*x3+……f[n]*xn)/(w[1][2]*x1+w[2][3]*x2+……w[n][1]*xn);

构造一个函数z(l)=(f[1]*x1+f[2]*x2+f[3]*x3+……f[n]*xn)-l*(w[1][2]*x1+w[2][3]*x2+……w[n][1]*xn);

简化为z(l)=sigma(f[i]*xi)-l*sigma(w[i][j]*xi);

变形得:r=sigma(f[i]*xi)/sigma(w[i][j]*xi)=l+z(l)/sigma(w[i][j]*xi);

当存在比l还大的比率的冲要条件是z(l)>0;即z(l)存在正环值就行,所以转化成了求正环的问题;

应该把点权和边权融合成关于边的量:K=f[u]-mid*w[u][v];然后用二分枚举比率mid,当有向连通图中存在正环,就把mid增大,否者减小;

程序:

#include"stdio.h"
#include"string.h"
#include"queue"
#include"stdlib.h"
#include"iostream"
#include"algorithm"
#include"string"
#include"iostream"
#include"map"
#include"math.h"
#define M 1005
#define eps 1e-8
#define inf 100000000
using namespace std;
struct node
{
    int v;
    double w;
    node(int vv,double ww)
    {
        v=vv;
        w=ww;
    }
};
vector<node>edge[M];
double dis[M],f[M];
int use[M],n;
double mid;
int dfs(int u)
{
    use[u]=1;
    for(int i=0;i<(int)edge[u].size();i++)
    {
        int v=edge[u][i].v;
        if(dis[v]<dis[u]+f[u]-mid*edge[u][i].w)
        {
            dis[v]=dis[u]+f[u]-mid*edge[u][i].w;
            if(use[v])
                return 1;
            if(dfs(v))
                return 1;
        }
    }
    use[u]=0;
    return 0;
}
int ok()
{
    memset(dis,0,sizeof(dis));
    memset(use,0,sizeof(use));
    for(int i=1;i<=n;i++)
        if(dfs(i))
        return 1;
    return 0;
}
int main()
{
    int m,i;
    while(scanf("%d%d",&n,&m)!=-1)
    {
        for(i=1;i<=n;i++)
            scanf("%lf",&f[i]);
        for(i=1;i<=n;i++)
            edge[i].clear();
        for(i=1;i<=m;i++)
        {
            int a,b;
            double c;
            scanf("%d%d%lf",&a,&b,&c);
            edge[a].push_back(node(b,c));
        }
        double left,right;
        left=0;
        right=100000;
        while(right-left>eps)
        {
            mid=(right+left)/2;
            if(ok())
                left=mid;
            else
                right=mid;
        }
        printf("%.2lf\n",left);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值