uva 11889 Benefit(简单数学)


                                                 Benefit

Recently Yaghoub is playing a new trick to sell some more. When somebody gives him A Tomans, he who never has appropriate changes, asks for B Tomans such that lowest common multiple of A and B equals to Cand he will pay back a round bill. Or otherwise take some snack instead of the remaining of his money. He believes that finding such a number is hard enough that dissuades students from paying that.

You should write a program that help poor students giving the appropriate amount of money to Yaghoub. Of course if there are several answers you go for students' benefit which is the lowest of them.

Input 

The first line begin with an integer  T  (  T$ \le$100000 ), the number of tests. Each test that comes in a separate line contains two integers  A  and  C  (  1$ \le$AC$ \le$107 ).

Output 

Print the lowest integer  B  such that  LCM(AB) = C  in a single line. If no such integer exists, print " NO SOLUTION " instead. (Quotes for clarity)

Sample Input 

3
2 6
32 1760
7 16

Sample Output 

3
55
NO SOLUTION
 
题意:给你a,c,然你求最小的b使得LCM(a,b)=c;,没有答案则输出“NO SOLUTION”;
 
c%a必须等于0,不等于0,输出NO SOLUTION ,c=g*a1*b1;求出b1=c/a;然后求出g,最后答案就是g*b1;
 
代码:
#include <iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<vector>
#include<stdlib.h>
#include<string>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<set>
#define inf 0x3f3f3f3f
#define eps 1e-5
#define max(a,b) (a)>(b)?(a):(b)
#define min(a,b) (a)<(b)?(a):(b)
using namespace std;
int gcd(int a,int b)
{
    if(!b)return a;
    return gcd(b,a%b);
}
int main()
{
    int t,a,c;
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            scanf("%d%d",&a,&c);
            if(c%a!=0)
            {
                printf("NO SOLUTION\n");
            }
            else
            {
                 int b=c/a;
                 int ans=1;
                 int gg=gcd(a>b?a:b,a>b?b:a);
                 while(gg>1)
                 {
                     a/=gg;
                     ans*=gg;
                     gg=gcd(a>b?a:b,a>b?b:a);
                 }
                 printf("%d\n",ans*b);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值