UVA 11889 - Benefit



  Benefit 
Recently  Yaghoub  is playing a new trick to sell some more. When somebody gives him  A  Tomans, he who never has appropriate changes, asks for  B  Tomans such that lowest common multiple of  A  and  B  equals to  C  and he will pay back a round bill. Or otherwise take some snack instead of the remaining of his money. He believes that finding such a number is hard enough that dissuades students from paying that.

You should write a program that help poor students giving the appropriate amount of money to Yaghoub. Of course if there are several answers you go for students' benefit which is the lowest of them.

Input 

The first line begin with an integer  T  (   T$ \le$100000 ), the number of tests. Each test that comes in a separate line contains two integers  A  and  C  (   1$ \le$AC$ \le$107 ).

Output 

Print the lowest integer  B  such that  LCM(AB) = C  in a single line. If no such integer exists, print " NO SOLUTION " instead. (Quotes for clarity)

Sample Input 

3
2 6
32 1760
7 16

Sample Output 

3
55
NO SOLUTION

题目大意:三个数关系 lcm(a,b)=c,已知a和c,求最小的b,没有输出-1

解题思路:b为c的约数,枚举b 满足gcd(a,b)*lcm(a,b)==a*b这个条件即可 ,但是注意乘法用 long long

#include <iostream>
#include <cstdio>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;

int gcd(int a,int b){
	return (b>0)?gcd(b,a%b):a;
}

int getb(int a,int c){
	if(c<a||c%a!=0) return -1;
	vector <int> v;
	int max0=int( sqrt(c*1.0)+0.1 );
	for(int i=1;i<=max0;i++){
		if(c%i==0){
			v.push_back(i);
			v.push_back(c/i);
		}
	}
	sort(v.begin(),v.end());
	for(int i=0;i<v.size();i++){
		int b=v[i],g=gcd(a,v[i]);
		if( (long long)a*(long long)b==(long long)g*(long long)c ) return b;
	}
	return -1;
}

int main(){
	int t,a,c;
	scanf("%d",&t);
	while(t-- >0){
		scanf("%d%d",&a,&c);
		int b=getb(a,c);
		if(b==-1) printf("NO SOLUTION\n");
		else printf("%d\n",b);
	}
	return 0;
}


转载于:https://www.cnblogs.com/toyking/p/3797373.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值