poj 3061

Subsequence  二分/尺取

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

题意:给出长为n的数列,求出总和不小于S的连续子序列的最小长度

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
long long sum[100100];
int T,S,n;
int judge(int x){
	for (int i=0;i+x-1<n;i++){//关键
		int l=i;int r=i+x;
		if (sum[r]-sum[i]>=S)
		return 1;
	}
	return 0;
}

int main(){
int ans,i,mid;
	int a[100100];
	scanf ("%d",&T);
	while (T--){
		memset(sum,0,sizeof(sum));
		scanf ("%d %d",&n,&S);
		for (i=0;i<n;i++){
			scanf ("%d",&a[i]);
			sum[i+1]=sum[i]+a[i];
		}
		int l=0;int r=n;
		ans=0;
		while (l<=r){
			mid=(l+r)/2;
			if (judge(mid)){
				r=mid-1;ans=mid;
			}
			else
			l=mid+1;
		}
		if (ans>n)
		ans=0;
		printf ("%d\n",ans);

	}
	return 0;
} 
二分复杂度O(nlogn)

1524K79MS

尺取法复杂度 

748K79MS

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值