习题5-6 使用函数输出水仙花数

习题5-6 使用函数输出水仙花数   (20分)

水仙花数是指一个NN位正整数(N\ge 3N3),它的每个位上的数字的NN次幂之和等于它本身。例如:153 = 1^3 + 5^3+ 3^3153=13+53+33。 本题要求编写两个函数,一个判断给定整数是否水仙花数,另一个按从小到大的顺序打印出给定区间(m,n)(m,n)内所有的水仙花数。

函数接口定义:

int narcissistic( int number );
void PrintN( int m, int n );

函数narcissistic判断number是否为水仙花数,是则返回1,否则返回0。

函数PrintN则打印开区间(mn)内所有的水仙花数,每个数字占一行。题目保证100\lem\len10000。

裁判测试程序样例:

#include <stdio.h>

int narcissistic( int number );
void PrintN( int m, int n );

int main()
{
    int m, n;

    scanf("%d %d", &m, &n);
    if ( narcissistic(m) ) printf("%d is a narcissistic number\n", m);
    PrintN(m, n);
    if ( narcissistic(n) ) printf("%d is a narcissistic number\n", n);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

153 400

输出样例:

153 is a narcissistic number
370
371

#include <stdio.h>  
#include <math.h>
  
int narcissistic( int number );  
void PrintN( int m, int n );  
  
int main()  
{  
    int m, n;  
  
    scanf("%d %d", &m, &n);  
    if ( narcissistic(m) ) printf("%d is a narcissistic number\n", m);  
    PrintN(m, n);  
    if ( narcissistic(n) ) printf("%d is a narcissistic number\n", n);  
  
    return 0;  
}  

int narcissistic( int number ){
	int i,n=0,sum=0,cnt=0;  
    n = number;  
    while(n){    
        cnt++;  
        n/=10;  
    }  
  
    n = number;  
    while(n){
		i=n%10;
        sum += (int)pow(i, cnt);
        n/=10; 
    }  
  
    if(sum == number)  
        return 1;  
    else  
        return 0;  

}

void PrintN( int m, int n ){  
  
    int i;  
  
    for(i=m+1;i<n;i++)  
        if(narcissistic(i))  
            printf("%d\n", i);  
}  


评论 13
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值