UVA1213 Sum of Different Primes(素数打表+dp)

UVA - 1213
Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Download as PDF

A positive integer may be expressed as a sum of different prime numbers (primes), in one way or another. Given two positive integers n andk, you should count the number of ways to express n as a sum of k different primes. Here, two ways are considered to be the same if they sum up the same set of the primes. For example, 8 can be expressed as 3 + 5 and 5 + 3 but they are not distinguished.

When n and k are 24 and 3 respectively, the answer is two because there are two sets {2, 3, 19} and {2, 5, 17} whose sums are equal to 24. There are no other sets of three primes that sum up to 24. For n = 24 and k = 2, the answer is three, because there are three sets {5, 19}{7, 17} and {11, 13}. For n = 2 and k = 1, the answer is one, because there is only one set {2} whose sum is 2. For n = 1 and k = 1, the answer is zero. As 1 is not a prime, you shouldn't count {1}. For n = 4 and k = 2, the answer is zero, because there are no sets of two different primes whose sums are 4.

Your job is to write a program that reports the number of such ways for the given n and k.

Input 

The input is a sequence of datasets followed by a line containing two zeros separated by a space. A dataset is a line containing two positive integers n and k separated by a space. You may assume that n$ \le$1120 and k$ \le$14.

Output 

The output should be composed of lines, each corresponding to an input dataset. An output line should contain one non-negative integer indicating the number of ways for n and k specified in the corresponding dataset. You may assume that it is less than 231.

Sample Input 

24 3 
24 2 
2 1 
1 1 
4 2 
18 3 
17 1 
17 3 
17 4 
100 5 
1000 10 
1120 14 
0 0

Sample Output 

2 
3 
1 
0 
0 
2 
1 
0 
1 
55 
200102899 
2079324314

Source

Root :: AOAPC II: Beginning Algorithm Contests (Second Edition) (Rujia Liu) :: Chapter 10. Maths ::  Exercises
Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Problem Solving Paradigms :: Dynamic Programming ::  0-1 Knapsack (Subset Sum)
Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Problem Solving Paradigms :: Dynamic Programming ::  0-1 Knapsack (Subset Sum)

 Status


题意是选择k个质数使其和为n,先搞一个素数表然后dp,dp[i][j]表示选了j个数和位i的方案数。



#include <bits/stdc++.h>
#define foreach(it,v) for(__typeof((v).begin()) it = (v).begin(); it != (v).end(); ++it)
using namespace std;
typedef long long ll;
const int maxn = 1120;
bool check[maxn];
int prime[1120];
ll dp[1122][15];
int init(int n)
{
    memset(check,0,sizeof check);
    int tot = 0;
    check[0] = check[1] = 1;
    for(int i = 2; i <= n; i++) {
        if(!check[i])prime[tot++] = i;
        for(int j = 0; j < tot; ++j) {
            if((ll)i*prime[j]>n)break;
            check[i*prime[j]] = true;
            if(i%prime[j]==0)break;
        }
    }
    return tot;
}
int main()
{
    int n,k;
    int tot = init(maxn-1);
    while(~scanf("%d%d",&n,&k)&&n) {
       memset(dp,0,sizeof dp);
       dp[0][0] = 1;
       for(int i = 0; prime[i]<=n&&i < tot; i++) {
            int limt = min(i+1,k);
            int w = prime[i];
            for(int V = n; V >= w; V--)
            for(int j = 1; j <= limt; j++)if(dp[V-w][j-1]){
                dp[V][j] += dp[V-w][j-1];
            }
       }
       cout<<dp[n][k]<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值