hdu 1361 Parencodings 模拟

Parencodings


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 727    Accepted Submission(s): 415




Problem Description
Let S = s1 s2 … s2n be a well-formed string of parentheses. S can be encoded in two different ways:


By an integer sequence P = p1 p2 … pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).


By an integer sequence W = w1 w2 … wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).




Following is an example of the above encodings:


  S    (((()()())))
  P-sequence      4 5 6666
  W-sequence      1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
 


Input
The first line of the input file contains a single integer t (1 t 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 n 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
 


Output
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
 


Sample Input
2
6
4 5 6 6 6 6

4 6 6 6 6 8 9 9 9
 


Sample Output
1 1 1 4 5 6

1 1 2 4 5 1 1 3 9



题意:

p 数组中第i个数代表 第i个) 前有多少(

要转化成 w数组  

w数组表示 ,从第i个) 向前算,直到与其匹配的(出现,一共有多少) 。     包括自己。


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <malloc.h>
#include <ctype.h>
#include <math.h>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
#include <stack>
#include <queue>
#include <vector>
#include <deque>
#include <set>
#include <map> 
 
int p[50],w[50];
int par[200];
int main()
{
	int n,t;
	cin>>t;
	while(t--)
	{
		cin>>n;

		int l=0;
		int pre=0;
		for(int i=0;i<n;i++)
		{
			scanf("%d",p+i);
			for(int j=0;j<p[i]-pre;j++)
			{
				par[l++]=0;//(
			}
			par[l++]=1;//)
			pre=p[i];
		}

		for(int i=0;i<l;i++)
		{
			if(par[i]==1)
			{ 
				int kk;
				int ji=1;
				int ans=0;
				for(kk=i-1;kk>=0;kk--)
				{
					if(par[kk]==1)
						ji++;
					else
						ji--;
					if(ji==0)
						break;
				}

				for(;kk<=i;kk++)
				{
					if(par[kk]==1)
						ans++; 
				}
				if(i==l-1)
					printf("%d\n",ans);
				else
					printf("%d ",ans);
			}

		}
	}
	return 0;	
}

/*
 S    (((()()())))
  P-sequence      4 5 6666
  W-sequence      1 1 1456


6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9
*/




 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值