Let the balloon rise

Let the Balloon Rise

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 59   Accepted Submission(s) : 23
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.(以0为结束标志)

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

 

本题题意是:

先输入一个数N,接下来几行,每一行都是一个气球的颜色。

写出算法,将出现次数最多的气球的颜色找出来,输出这个颜色。

 

重点:

1.多组数据输入

2.N是个大数,而气球颜色单词本身也由多个字母组成

 

思路:

开二维数组,第一维代表每一个单词,第二维表示每个单词内部的字母,是一个小数组。方便比较两个单词是否一样,进而进行统计。

 

#include<stdio.h>
#include<string.h>
int main(){
    char a[1001][16];
    int t;
    int n,i,j,max,flag;
    while(scanf("%d",&n)&&n)
    { 
        getchar();
        for(i=0;i<n;i++)
        {
            gets(a[i]);
        }
        max=1;    
        flag=0; 
        for(i=0;i<n;i++)
        {    
            t=1;
            if(a[i][0]=='\0') continue;
            for(j=i+1;j<n;j++)
            {
                if(a[j][0]=='\0') continue;
                if(strcmp(a[i],a[j])==0)
                {
                    t++;
                    a[j][0]='\0';
                }  
            }
            if(t>max)
            {
                max=t;
                flag=i;
            }
        }
        puts(a[flag]);
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值