L - Let the Balloon Rise

题目:

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters. 

A test case with N = 0 terminates the input and this test case is not to be processed. 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case. 

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

题意:

给你一个数字 N ,代表有N个气球,让你求出出现次数最多的气球的颜色;

代码如下:

(1)使用数组:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int t;
char map[10001][20];//存储气球的颜色;
int sum[10001];

int main()
{
    while(~scanf("%d",&t)&&t)
    {
        memset(sum,0,sizeof sum);
        int i,j;
        for(i=0;i<t;i++)
        {
            scanf("%s",map[i]);
            for(j=0;j<i-1;j++)
            {
                if(strcmp(map[i],map[j])==0)//把这个气球的颜色和以前出现过的气球进行比较,如果颜色相同就加1;
                    sum[i]=sum[i]+1;//前面的没出现一个颜色相同的,这个颜色的气球个数就加1;
            }
        }
        int s=0;
        for(i=0;i<t;i++)//进行遍历,找出出现次数最多的颜色;
        {
            if(sum[i]>s)
            {
                s=i;//标记出现次数最多的颜色是第几个气球;
            }
        }
        printf("%s\n",map[s]);//输出这个气球的颜色;
    }
    return 0;
}

(2)使用map容器:

#include<iostream>
#include<map>
#include<string>
#include<algorithm>
using namespace std;

const int MAX=10010;

int main()
{
    int n;
    char col[20];
    while(cin>>n)
    {
        if(n==0)
            break;
        map<string,int> balloons;
        for (int i=0; i<n; i++)
        {
            cin>>col;
            balloons[col]++;
        }
        map<string,int>::iterator p,m;
        p=m=balloons.begin();
        for (; p!=balloons.end(); p++)
        {
            if(p->second > m->second) m=p;
        }
        cout<<m->first<<endl;
    }
}

 

  • 4
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值