POJ 2398 Toy Storage 计算几何(点与直线的关系)

Toy Storage
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4034 Accepted: 2394

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

题意:这题和 POJ 2318 几乎一样,就是隔板的顺序没有排好,最后输出的是含有 i 个玩具的个数
题目链接:http://poj.org/problem?id=2398

题解:同 POJ 2318
POJ 2318题解链接:http://blog.csdn.net/u013557725/article/details/40120017
解法一:
/**********
    Problem: 2398		User: pluto227
    Memory: 212K		Time: 0MS
    Language: C++		Result: Accepted
**********/
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#define DEBUGMODE
#define eps 1e-6
#define LL long long
using namespace std;

const int N = 5000+100;
int num[N];

struct node {
    double x1,x2;
    double k,b;
} line[N];

int cmp(node x,node y) {
    return x.x1<y.x1;
}

int main() {
    int n,m;
    double x1,y1,x2,y2;
    while(~scanf("%d",&n),n) {
        scanf("%d %lf %lf %lf %lf",&m,&x1,&y1,&x2,&y2);
        for(int i=0; i<n; i++) {
            scanf("%lf %lf",&line[i].x1,&line[i].x2);
            if(line[i].x1==line[i].x2) {
                line[i].k=0,line[i].b=0;
                continue;
            }
            line[i].k=(y1-y2)/(line[i].x1-line[i].x2);
            line[i].b=y1-line[i].x1*line[i].k;
        }
        line[n].k=line[n].b=0;
        line[n].x1=line[n].x2=x2;
        sort(line,line+n,cmp);
        memset(num,0,sizeof(num));
        double x,y;
        for(int i=0; i<m; i++) {
            scanf("%lf %lf",&x,&y);
            for(int j=0; j<=n; j++) {
                if(fabs(line[j].k-0)<eps) {
                    if(x<line[j].x1) {
                        num[j]++;
                        break;
                    }
                } else if(line[j].k-0>eps) {
                    if(y>line[j].k*x+line[j].b) {
                        num[j]++;
                        break;
                    }
                } else if(line[j].k<0) {
                    if(y<line[j].k*x+line[j].b) {
                        num[j]++;
                        break;
                    }
                }
            }
        }
        int cnt[N]={0};
        for(int i=0; i<=n; i++) {
            if(num[i]==0) continue;
            cnt[num[i]]++;
        }
        printf("Box\n");
        for(int i=1;i<=m;i++){
            if(cnt[i]==0) continue;
            printf("%d: %d\n",i,cnt[i]);
        }
    }
    return 0;
}

解法二:
/**********
    Problem: 2398		User: pluto227
    Memory: 212K		Time: 16MS
    Language: C++		Result: Accepted
**********/
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#define DEBUGMODE
#define EPS 1e-6
#define LL long long
using namespace std;

const int N = 5000+10;
int sum[N];

struct point {
    double x;
    double y;
};

struct Line {
    point a;
    point b;
} line[N];

double multi(point p0,point p1,point p2) {
    return (p0.x-p1.x)*(p2.y-p1.y)-(p2.x-p1.x)*(p0.y-p1.y);
}

int cmp(Line x,Line y) {
    return x.a.x<y.a.x;
}

void B_search(point p,int n) {
    int l=0,r=n-1;
    int mid;
    while(l<r) {
        mid=(l+r)>>1;
        if(multi(p,line[mid].b,line[mid].a)>0) l=mid+1;
        else r=mid;

    }
    if(multi(p,line[l].b,line[l].a)>0) sum[l+1]++;
    else sum[l]++;
}

int main() {
    int n,m;
    double x1,y1,x2,y2;
    while(~scanf("%d",&n)&&n) {
        memset(sum,0,sizeof(sum));
        scanf("%d %lf %lf %lf %lf",&m,&x1,&y1,&x2,&y2);
        for(int i=0; i<n; i++) {
            double p_x1,p_x2;
            scanf("%lf %lf",&p_x1,&p_x2);
            line[i].a.x=p_x1;
            line[i].a.y=y1;
            line[i].b.x=p_x2;
            line[i].b.y=y2;
        }
        sort(line,line+n,cmp);
        for(int i=0; i<m; i++) {
            double x,y;
            scanf("%lf %lf",&x,&y);
            point p;
            p.x=x;
            p.y=y;
            B_search(p,n);
        }
        int cnt[N]={0};
        for(int i=0; i<=n; i++) {
            if(sum[i]==0) continue;
            cnt[sum[i]]++;
        }
        printf("Box\n");
        for(int i=1;i<=m;i++){
            if(cnt[i]==0) continue;
            printf("%d: %d\n",i,cnt[i]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值