计算几何——Toy Storage(叉积)

原文链接:poj.org/problem?id=2398

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:


We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

题目翻译:

描述

        有一个叫Reza的小孩很皮,当他玩好玩具之后从来都不放回去.爸爸妈妈给了他一个矩形的盒子来收纳他的玩具.不过Reza很皮,每次只是简单的把玩具扔到箱子里.所以所有玩具混在了一起Reza就再也找不到他最喜欢的玩具了.
        爸爸妈妈想出了如下主意:他们往箱子里插了一些隔板.即使Reza继续把玩具扔到盒子里,至少玩具们会被分到不同的隔间.这个盒子俯视图:
        我们想知道对于每一个正整数t,有多少个隔间刚好有t个玩具

输入

        输入由一些样例组成.每个样例第一行有6个整数n,m,x1,y1,x2,y2.隔板数量n(0<n<=1000)和玩具数量m(0<m<=0=1000).(x1,y1)和(x2,y2)是矩形左上角和右下角的坐标接下来n行每行两个数字Ui,Di代表着隔板上坐标(Ui,y1)和下坐标(Di,y2).你可以假定隔板们不会相交,再接下来m行每行两个数字x,y代表着玩具落地时的坐标(x,y).你还可以假定玩具不会落在隔板上
        一行单独的0代表着输入结束.

输出

对于每个盒子,第一行输出"Box".然后输出一个数字代表t,一个冒号和空格,紧跟着的是恰好有t个玩具个隔间数量.输出顺序按照t的大小从小到大输出

这个题和上个题的做法差不多,只是输出变了,而且要排个序.

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1e3+7;
struct Point{
	double x,y;
	Point(double x=0,double y=0):x(x),y(y){}
};
typedef Point Vector;
Vector operator - (Point A,Point B){
	return Vector(A.x-B.x,A.y-B.y);
} 
double Cross(Vector A,Vector B){
	return A.x*B.y-A.y*B.x;
}
bool TurnToLeft(Point a,Point b,Point c){
	if(Cross(b-a,c-b)>0) return true;
	else if(Cross(b-a,c-b)<0) return false;
}
int cnt[maxn],b[maxn];
pair<double,double> a[maxn];
int main(int argc, char** argv) {
	int n,m;
	double x1,y1,x2,y2;
	int flag=0;
	while(scanf("%d%d%lf%lf%lf%lf",&n,&m,&x1,&y1,&x2,&y2)&&n){
	    printf("Box\n");
		memset(cnt,0,sizeof(cnt));
		memset(b,0,sizeof(b));
		for(int i = 1;i<=n;i++){
			scanf("%lf%lf",&a[i].first,&a[i].second);
		}	
		a[0].first=x1;
		a[0].second=x1;
		a[n+1].first=x2;
		a[n+1].second=x2;
		sort(a,a+n+1);
		while(m--){
			double x,y;
			scanf("%lf%lf",&x,&y);
			if(x<x1||y>y1||x>x2||y<y2) continue;
			for(int i = 1;i<=n+1;i++){
				Point r1,s1,t,r2,s2;
				r1.x=a[i-1].first;
				r1.y=y1;
				s1.x=a[i-1].second;
				s1.y=y2;
				
				
				r2.x=a[i].first;
				r2.y=y1;
				s2.x=a[i].second;
				s2.y=y2;
				
				t.x=x;
				t.y=y;
				if(!TurnToLeft(s1,r1,t)&&TurnToLeft(s2,r2,t)) cnt[i-1]++;
			}
		}
		for(int i = 0;i<=n;i++)
			if(cnt[i])
			  b[cnt[i]]++;
		for(int i = 0;i<=maxn;i++)
			if(b[i])
			   printf("%d: %d\n",i,b[i]);
	}
	return 0;
}

 

 

 

 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值