POJ - 1323 Game Prediction

Game Prediction
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11071 Accepted: 5338

Description

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game. 



Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game. 

Input

The input consists of several test cases. The first line of each case contains two integers m (2?20) and n (1?50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases. 

The input is terminated by a line with two zeros. 

Output

For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game. 

Sample Input

2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0

Sample Output

Case 1: 2
Case 2: 4

Source


题意:
有m个人在玩牌,平均每人发n张牌,则总共发了n*m张牌。输入你拿到的牌,每轮每人出一张牌比大小,让你求你至少能赢几轮的最大值。
举个例子:
2 5
1 7 2 10 9
你拿到的牌按从大到小排列为:
10 9 7 2 1
2人中最大的牌为10,那么10,9就是必赢牌,别人手里有一张8,你的7就不能保证赢过别人,但可以消耗别人一张8。别人手里还有6,5,4,3,你手里的2,1也不能保证赢过别人。所以答案为2。

题解:
由于本题的数据规模不大,就可以用一个bool数组来标记你得到的牌。res记录你必赢的回合,sum记录别人手里比你手里当前最大的牌还大的牌数。从大到小遍历bool数组,遇到值为false的sum++,遇到值为true的就消耗一张sum,若sum已经为0了,说明这张牌是当前局面中最大的牌,res++。代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int m,n,a[55];
bool vis[1005];
int main()
{
    int cas=0;
    while(scanf("%d%d",&m,&n) && n+m)
    {
        memset(vis,0,sizeof(vis));
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            vis[a[i]]=1;
        }
        int sum=0,res=0;
        for(int i=m*n; i>0; i--)
        {
            if(vis[i])
            {
                if(sum==0)
                    res++;
                else
                    sum--;
            }
            else
                sum++;
        }
        printf("Case %d: %d\n",++cas,res);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值