Game of Taking Stones(威佐夫博奕 待整理)

Game of Taking Stones

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 477    Accepted Submission(s): 184


Problem Description
Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.Now,giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy?
 

Input
Input contains multiple sets of test data.Each test data occupies one line,containing two non-negative integers a andb,representing the number of two stones.a and b are not more than 10^100.
 

Output
For each test data,output answer on one line.1 means you are the winner,otherwise output 0.
 

Sample Input
  
  
2 1 8 4 4 7
 

Sample Output
  
  
0 1 0
 

Source
 

Recommend
wange2014
 
本来就是一个简单的威佐夫博奕,但是因为大数!!!

#include <bits/stdc++.h>
using namespace std;

#define exp 1e-14

int main()
{
//    printf("%f\n", pow(10, 100));
    double gr = (sqrt(5.0) + 1) / 2;
    //printf("gr = %f\n", gr);
	double a, b, t;
	double k;
	while (~scanf("%lf%lf", &a, &b)) {
        if (a > b) {
            t = a;
            a = b;
            b = t;
        }
	    k = (b - a) * gr;
	    //printf("k = %f\n", k);
	    if ((-exp < k - a && k - a < exp) || (k > a && k - a < 1.0)) {
            printf("0\n");
	    } else {
            printf("1\n");
	    }
	}
    return 0;
}


因为10^100,所以黄金分割需要精确到100位

import java.math.*;
import java.math.BigDecimal;  
import java.util.Scanner;

public class Main {//类名要用Main
    public static void main(String[] args){
        BigDecimal TWO = BigDecimal.valueOf(2);  
        BigDecimal FIVE = BigDecimal.valueOf(5); 
        
        
        BigDecimal EPS = new BigDecimal(  
                "-0.0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001");  
        BigDecimal l = new BigDecimal("2.2360679774997"), r = new BigDecimal("2.2360679774998");  
        BigDecimal m = null;  
        while (l.subtract(r).compareTo(EPS) < 0)  
        {  
            m = l.add(r).divide(TWO);  
            if (m.multiply(m).subtract(FIVE).abs().compareTo(EPS.abs()) < 0)  
                break;  
            if (m.multiply(m).subtract(FIVE).compareTo(EPS) < 0)  
                l = m;  
            else  
                r = m;  
        }  
         BigDecimal gold = m.add(BigDecimal.ONE).divide(TWO);  
        
        BigDecimal a2, b2,k;
    	BigInteger a, b, t,k2;
    	Scanner sc=new Scanner(System.in);
    	while (sc.hasNextBigInteger()) {
    		a=sc.nextBigInteger();
            b=sc.nextBigInteger();
            if (a.compareTo(b) > 0) {
                t = a;
                a = b;
                b = t;
            }
            a2 = new BigDecimal(a);
            b2 = new BigDecimal(b);
            
    	    k = b2.subtract(a2).multiply(gold);
    	    k2 = k.toBigInteger();
    	    
    	    if (k2.compareTo(a) == 0) {
    	    	System.out.println("0");
    	    } else {
                System.out.println("1");
    	    }
    	}
        
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值