POJ 3641 Pseudoprime numbers (快速幂)

Pseudoprime numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9817 Accepted: 4170
Description

Fermat’s theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing “0 0”. Each test case consists of a line containing p and a.

Output

For each test case, output “yes” if p is a base-a pseudoprime; otherwise output “no”.

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0
Sample Output

no
no
yes
no
yes
yes

题意:输入p,a,两个数如果p是素数输出no,如果p不是素数,判断a^p%p==a是否成立,如果成立输出yes,否则输出no

题解:快速幂取模

快速幂取模模板:

typedef long long ll;
ll mod(ll a,ll b,ll m)//a^p%p == a
{
    long long ans = 1;
    while(b>0)
    {
        if(b&1)
        {
            ans = ans*a%m;
        }
        b>>=1;
        a = a*a%m;
    }
    return ans;
}

AC代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;
typedef long long ll;
ll a,p;
int is_prime(ll p)//朴素的素性测试
{
    for(int i=2;i*i<=p;i++)
    {
        if(p%i == 0)
            return false;
    }
    return p != 1;
}
ll mod(ll a,ll b,ll m)//a^p%p == a
{
    long long ans = 1;
    while(b>0)
    {
        if(b&1)
        {
            ans = ans*a%m;
        }
        b>>=1;
        a = a*a%m;
    }
    return ans;
}
int main()
{
    while(cin>>p>>a&&p||a)
    {
        ll ans;
        if(is_prime(p))
            cout<<"no"<<endl;
        else
        {
            ans = mod(a,p,p);
            if(ans == a)
                cout<<"yes"<<endl;
                else
                    cout<<"no"<<endl;
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值