kuangbin带你飞:专题一 简单搜索 L - Oil Deposits

kuangbin带你飞:专题一 简单搜索

L - Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either * , representing the absence of oil, or @ , representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
@@*
@
@@*
1 8
@@**@*
5 5
**@
@@@
@*@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

题意就是上下左右和四个对角线方向都算可连通的,那么求解强连通分量个数。由于这一题是地图的形式,我的想法是对于每个点BFS,前提是它没有被之前的点BFS后标记掉,将满足执行BFS的点的个数数一遍就代表了强连通分量的个数。

#include<bits/stdc++.h>
using namespace std;
const int siz=102;
char maps[siz][siz];
bool vis[siz][siz];
int dir[8][2]={
        1,0,
        0,1,
        -1,0,
        0,-1,
        -1,-1,
        1,1,
        1,-1,
        -1,1
    };
struct node
{
    int x ,y;
};
vector <node> rec;
int m,n;
bool judge(int x,int y)
{
    if(x>=0&&x<m&&y>=0&&y<n&&maps[x][y]=='@')
    {
        return 1;
    }
    return 0;
}
void bfs(node ans)
{
    queue <node> q;
    q.push(ans);
    vis[ans.x][ans.y]=1;
    while(!q.empty())
    {
       node tem=q.front();
       q.pop();
       int nx=tem.x;
       int ny=tem.y;
       for(int i=0;i<8;i++)
       {
           if(judge(nx+dir[i][0],ny+dir[i][1])&&!(vis[nx+dir[i][0]][ny+dir[i][1]]))
           {
               vis[nx+dir[i][0]][ny+dir[i][1]]=1;
              // cout<<"mark :"<<nx+dir[i][0]<<"  "<<ny+dir[i][1]<<endl;
               node neo;
               neo.x=nx+dir[i][0];
               neo.y=ny+dir[i][1];
               q.push(neo);
           }
       }
    }
}
void clean()
{
    while(!rec.empty())
    {
        rec.pop_back();
    }
}
int main()
{
    while(cin>>m>>n&&m)
    {
        memset(vis,0,sizeof vis);
        clean();
        for(int i=0;i<m;i++)
        {
            for(int j=0;j<n;j++)
            {
                cin>>maps[i][j];
                if(maps[i][j]=='@')
                {
                    node tem;
                    tem.x=i;
                    tem.y=j;
                    rec.push_back(tem);
                }
            }
        }
        int len=rec.size();
        int cnt=0;
        //cout<<"len  :"<<len<<endl;
        for(int i=0;i<len;i++)
        {
            node ans=rec[i];
            if(!vis[ans.x][ans.y])
            {
                bfs(ans);
                cnt++;
            }
        }
       /* for(int i=0;i<m;i++)
        {
            for(int j=0;j<n;j++)
            {
                cout<<vis[i][j]<<' ';
            }
            cout<<endl;
        }*/
        cout<<cnt<<endl;

    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值