[kuangbin带你飞]专题1 简单搜索 L - Oil Deposits HDU - 1241

题目:

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36263    Accepted Submission(s): 21010


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2

题意:@为有油的位置,*为没有油的位置,若@相邻的八个方向中有某位置也为@,则认为这两个位置为同一处油田。问输入的数据中有多少油田?


思路:BFS求连通快。遍历图,若其中某一个位置为@,则以这个点为起点,开始一次BFS,所有BFS到达的地方都更新为‘*’。最终BFS的次数就是连通块的个数。


#include<bits/stdc++.h>

typedef long long ll;

using namespace std;

char mapp[110][110];
int n,m;
int ans;
int dir[8][2] = {{-1,0},{-1,1},{0,1},{1,1},{1,0},{1,-1},{0,-1},{-1,-1}};  //八个方向 

void bfs(int i , int j){
	queue< pair<int,int> > q;
	q.push(make_pair(i,j));
	
	while (!q.empty()){
		pair<int,int> temp = q.front();
		q.pop();
		
		int x = temp.first;
		int y = temp.second;
		for(int i = 0 ; i<8 ; i++){
			int nxtx = x + dir[i][0];     
			int nxty = y + dir[i][1];    
			
			if(nxtx<0 || nxty<0 || nxtx>=n || nxty>=m)  //下个位置在图之外 
				continue;
			if(mapp[nxtx][nxty] == '*')                 //下个位置没有油 
				continue;
			
			mapp[nxtx][nxty] = '*';                      
			q.push(make_pair(nxtx,nxty));
		}
	}
}

int main(){
	ios::sync_with_stdio(false);
	while(cin>>n>>m){
		if(n==0 && m==0)
			break;
		ans = 0;
		
		for(int i = 0 ; i<n ; i++){
			cin>>mapp[i];
		}
		for(int i = 0 ; i<n ; i++){
			for(int j = 0 ; j<m ; j++){
				if(mapp[i][j] == '@'){
					bfs(i,j);
					ans++;
				}
			}
		}
		cout<<ans<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值