hdu 4280 Island Transport (最大流)

http://acm.hdu.edu.cn/showproblem.php?pid=4280

Island Transport

Problem Description
  In the vast waters far far away, there are many islands. People are living on the islands, and all the transport among the islands relies on the ships.
  You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
  The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.
Input
  The first line contains one integer T (1<=T<=20), the number of test cases.
  Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
  Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
  Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
  It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.
Output
  For each test case, output an integer in one line, the transport capacity.
Sample Input
  
  
2 5 7 3 3 3 0 3 1 0 0 4 5 1 3 3 2 3 4 2 4 3 1 5 6 4 5 3 1 4 4 3 4 2 6 7 -1 -1 0 1 0 2 1 0 1 1 2 3 1 2 1 2 3 6 4 5 5 5 6 3 1 4 6 2 5 5 3 6 4
Sample Output
  
  
9 6

题目大意:

有N个岛屿,M条路线,每条路都连接两个岛屿,并且每条路都有一个最大承载人数,现在想知道从最西边的岛到最东面的岛最多能有多少人过去(最西面和最东面的岛屿只有一个)。


很水的一道最大流问题,用最基本的dinic就可以解决了,只是数据比较大,一定要记得手动扩栈,就是因为之前写代码的时候以为只用邻接表就可以过了,结果RE了好多次。

#pragma comment (linker, "/STACK:102400000,102400000")

#include <iostream>
#include <queue>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <stack>
#include <vector>
#include <map>

using namespace std;

#define N 1350000
#define INF 0xfffffff
#define PI acos (-1.0)
#define EPS 1e-8

struct node1
{
    int v, next, flow;
}edge[N];

struct node
{
    int x, y, index;
}p[N];

bool cmp (node a, node b)
{
    return a.x < b.x;
}

int head[N], layer[N], cnt;

void Init ();
void addedge (int u, int v, int flow);
bool BFS (int sa, int en);
int DFS (int sa, int maxflow, int en);
int dinic (int sa, int en);

int main ()
{
    int t, n, m;
    scanf ("%d", &t);

    while (t--)
    {
        Init ();
        scanf ("%d %d", &n, &m);

        for (int i=0; i<n; i++)
        {
            scanf ("%d %d", &p[i].x, &p[i].y);
            p[i].index = i+1;
        }
        sort (p, p+n, cmp);///排序找到源点和汇点

        int I1, I2, flow;
        for (int i=1; i<=m; i++)
        {
            scanf ("%d %d %d", &I1, &I2, &flow);
            addedge (I1, I2, flow);
        }

        int sa = p[0].index, en = p[n-1].index;

        printf ("%d\n", dinic (sa, en));
    }
    return 0;
}

void Init ()
{
    memset (head, -1, sizeof (head));
    cnt = 0;
}

void addedge (int u, int v, int flow)
{
    edge[cnt].v = v;
    edge[cnt].next = head[u];
    edge[cnt].flow = flow;
    head[u] = cnt++;

    swap (u, v);

    edge[cnt].v = v;
    edge[cnt].next = head[u];
    edge[cnt].flow = flow;
    head[u] = cnt++;

}

bool BFS (int sa, int en)
{
    memset (layer, 0, sizeof (layer));
    queue <int> que;
    que.push (sa);
    layer[sa] = 1;

    while (que.size ())
    {
        sa = que.front (); que.pop ();

        if (sa == en) return true;

        for (int i=head[sa]; i!=-1; i=edge[i].next)
        {
            int v = edge[i].v;
            if (!layer[v] && edge[i].flow)
            {
                layer[v] = layer[sa] + 1;
                que.push (v);
            }
        }
    }
    return false;
}

int DFS (int sa, int maxflow, int en)
{
    if (sa == en) return maxflow;

    int uflow = 0;

    for (int i=head[sa]; i!=-1; i=edge[i].next)
    {
        int v = edge[i].v;
        if (layer[v] == layer[sa]+1 && edge[i].flow)
        {
            int flow = min (maxflow - uflow, edge[i].flow);
            flow = DFS (v, flow, en);

            edge[i].flow -= flow;
            edge[i^1].flow += flow;
            uflow += flow;

            if (uflow == maxflow) break;
        }
    }

    if (!uflow) layer[sa] = 0;
    return uflow;
}

int dinic (int sa, int en)
{
    int maxflow = 0;
    while (BFS (sa, en))
        maxflow += DFS (sa, INF, en);
    return maxflow;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_大太阳_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值