02-线性结构4 Pop Sequence (25分)

Given a stack which can keep MMM numbers at most. Push NNN numbers in the order of 1, 2, 3, …, NNN and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if MMM is 5 and NNN is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): MMM (the maximum capacity of the stack), NNN (the length of push sequence), and KKK (the number of pop sequences to be checked). Then KKK lines follow, each contains a pop sequence of NNN numbers. All the numbers in a line are separated by a space.
Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

#include<iostream>
#include<stack>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
int M,N,K;
int check(vector<int> &v){
    int idx=0,num=1,cap=M+1;
    stack<int> sta;
    sta.push(0);
    while(idx<N){
//当v[idx]的值大于栈顶序列时说明它前面的值已经全部压入栈里了,如果此时栈还不满则继续入栈
        while(v[idx]>sta.top()&&sta.size()<cap)
            sta.push(num++);
        if(v[idx++]==sta.top())     sta.pop();//如果v[idx]的值等于栈顶序列则pop出去这个元素,且idx++
        else return 0;
    }
    return 1;
}
int main(){
    vector<int> vec(N,0);//N为个数,0为初始值
    scanf("%d%d%d",&M,&N,&K);
    for(int i=0;i<K;i++){
        for(int j=0; j<N; j++){
            int temp;
            scanf("%d",&temp);
            vec.push_back(temp);
        }
        if(check(vec))  printf("YES\n");
        else    printf("NO\n");
        vec.clear();            //最后记得清空vector用于第二次输入
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值