数据结构——02-线性结构4 Pop Sequence

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

给定一个最多可以保留M个数字的堆栈。按1、2、3、…的顺序推N个数字, N,随机弹出。你应该告诉一个给定的数字序列是否可能是堆栈的弹出序列。例如,如果M是5,N是7,我们可以从堆栈中得到1、2、3、4、5、6、7,但不能得到3、2、1、7、5、6、4。

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

输入规格:
每个输入文件包含一个测试用例。对于每种情况,第一行包含3个数字(都不超过1000):M(堆栈的最大容量)、N(推序列的长度)和K(要检查的弹出序列的数量)。然后是K行,每一行包含一个包含N个数字的弹出序列。一行中的所有数字都用空格隔开。

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

输出规范:
对于每个弹出序列,如果它确实是堆栈中可能的弹出序列,则在一行中打印“YES”,如果不是则打印“NO”。

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

题意为,给出K个序列,每个序列有N个成员,分别判断是否可以从栈的入栈出栈操作得到这个序列。 入栈数据为1、2、3……M,栈的最大容量为M。

思路一:

当栈不空时,逐一核对给出序列的每个元素,当该元素小于栈顶元素,说明该元素无法按此顺序弹出,序列错误;当该元素等于栈顶元素,出栈、核对下一个元素;当该元素大于栈顶元素,说明该元素还未入栈,进行入栈操作,一直到该元素入栈或者栈满。

代码如下:

#include <stdio.h>
#include <stdlib.h>
#define MAX 1000
typedef struct node{
	int data[MAX];
	int top;
	int capacity;
}Stack;
int isPopquence(int array[],int n,int m);
int main(int argc,char const *argv[]){
	int m=0,n=0,k=0;
	scanf("%d%d%d",&m,&n,&k);
	int array[n];
//	FILE *fp=fopen("test.txt","r");
	for(int i=0;i<k;i++){
		for(int j=0;j<n;j++){
			scanf("%d",&array[j]);
		}
		if(isPopquence(array,n,m)){
			printf("YES\n");
		}else{
			printf("NO\n");
		}
	}
//	fclose(fp);
	return 0;
}
int isPopquence(int array[],int n,int m){
	Stack *pStack=(Stack*)malloc(sizeof(Stack));
	pStack->top=-1;
	pStack->capacity=m;
	int res=1,data=1;
	for(int i=0;i<n;i++){
		if(pStack->top==-1) pStack->data[++pStack->top]=data++;
		if(array[i]<pStack->data[pStack->top]){
			res=0;break;
		}else if(array[i]==pStack->data[pStack->top]){
			pStack->top--;
		}else{
			while(pStack->top+1!=pStack->capacity&&array[i]!=pStack->data[pStack->top]){
				pStack->data[++pStack->top]=data++;
			}
			if(array[i]==pStack->data[pStack->top]){
				pStack->top--;
			}else{
				res=0;break;
			}
		}
	}
	return res;
}

思路二:

一个大佬给出的在线求解,看着程序发现如此神妙。。。 

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define Maxsize 1000//最大容量
typedef struct Node{
	int Top;//栈顶
	int Data[Maxsize];//元素
	int Capacity;//容量
}*Stack;

int IsPopPossible(int Arry[],int M,int N);//判断是否可能为出栈序列 
int main()
{
	int M = 0,N = 0,K = 0,i = 0,j = 0;
	scanf("%d %d %d",&M,&N,&K);//条件读入 
	int Arry[N];//数据存储 
	for(i = 0;i <= K-1;i++){
		for(j = 0;j <= N-1;j++)//每一行数据读入 
			scanf("%d",&Arry[j]);
		if(IsPopPossible(Arry,M,N))//非零时表示可能存在 
			printf("YES\n");
		else 
			printf("NO\n");
	}
	return 0;
}
int IsPopPossible(int Arry[],int M,int N)
{
	int i = 0,flag = 0,count = 0;
	Stack Pile = (Stack)malloc(sizeof(struct Node));//申请并初始化一个空栈 
	Pile->Capacity = M;
	Pile->Top = -1;
	for(i = 1;i <= N;i++){
		if(Pile->Capacity == Pile->Top+1)//栈满 
			return 0;
		else
			Pile->Data[++Pile->Top] = i;//入栈 
		while(Pile->Data[Pile->Top] == Arry[count]){//比较栈顶是否与某数相等 
			Pile->Top--;//出栈 
			count++;//数组往后移位 
		}
	}
	if(count == N)//全部找到并且输出时 
		return 1;
	else 
		return 0; 
}

 原帖传送门:http://t.csdn.cn/QR3Bxicon-default.png?t=M85Bhttp://t.csdn.cn/QR3Bx

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值