Prime Distance poj 2689 区间内的素数打表模板

本文详细解析了POJ 2689题目,探讨如何利用素数打表模板解决区间内的素数问题。通过数论知识和巧妙的算法设计,实现高效计算两个素数之间的距离。同时,文章还介绍了在C++中使用namespace避免命名冲突的重要性。
摘要由CSDN通过智能技术生成
Prime Distance
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10977 Accepted: 2957

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source



先素数打表,把大范围的素数求出并标记,然后再把区间范围内的素数进行打表,再进行比较,求出最大和最小的范围素数

#include<iostream>
#include<cstdio>
#include<cstring>
#include<math.h>
using namespace std;
#define  M   1000005
#define  N  1 << 17
int l, u;
bool is[N];//大范围的判断素数
long long prm[N];//大范围的素数打表
int n;
bool ans[M];//判断区间内那些是素数
int prime[M];//把区间内素数记录下来
int num;//记录区间内的素数个数
int primed(int n)
{
    int i, j, k = 0;
    int s, e = (int) (sqrt(0.0 + n) + 1);
    memset(is, 1, sizeof(is));
    prm[k++] = 2;
    is[0] = is[1] = 0;
    for (i = 3; i < e; i += 2)
        if (is[i])
        {
            prm[k++] = i;
            for (s = i * 2, j = i * i; j < n; j += s)
                is[j] = 0;
        }
    for (; i < n; i += 2)
        if (is[i])
            prm[k++] = i;
    return k;
}
int main()
{

    n = primed(1<<16);//记录共有多少个素数
    while(scanf("%d%d",&l,&u)!=EOF)
    {
        for (int i = 0; i < u - l + 1; i++)
            ans[i] = true;
        if (l == 1)
            ans[0] = false;
        num = 0;
       /* for(int i=0; i<10; i++)
        {
            printf("prm %d\n",prm[i]);
        }*/
        for (int i = 0; i < n && prm[i] * prm[i] <= u; i++)
        {
            long long temp = (l + prm[i] - 1) / prm[i] * prm[i];
            /* if(i==0)
             {
                 printf("a%lld  b%lld  c%lld %lld\n",temp,l + prm[i]- 1,prm[i],prm[i]*prm[i]);
             }*/
            if (temp == prm[i])
                temp += prm[i];
            while (temp <= u)
            {
                ans[temp - l] = false;
                temp += prm[i];
            }
        }
       /* for(int i=0; i<u-l+1; i++)
        {
            printf("%d\n",ans[i]);
        }*/
        for (int i = 0; i < u - l + 1; i++)
            if (ans[i])
                prime[num++] = l + i;
       // for(int i=0; i<num; i++)
       //printf("pppppppppp  %d\n",prime[i]);
        if (num < 2)
        {
            printf("There are no adjacent primes.\n");
           
        }
        else
        {
            
        
        int ans1 = 0, ans2 = 0;
        for (int i = 0; i < num - 1; i++)
        {
            if (prime[ans1 + 1] - prime[ans1] > prime[i + 1] - prime[i])
                ans1 = i;
            if (prime[ans2 + 1] - prime[ans2] < prime[i + 1] - prime[i])
                ans2 = i;
        }
        printf("%d,%d are closest, %d,%d are most distant.\n", prime[ans1], prime[ans1 + 1], prime[ans2], prime[ans2 + 1]);

        }


    }
    return 0;
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值