poj 3311 Hie with the Pie(floyd + 状压dp)

52 篇文章 0 订阅
33 篇文章 0 订阅
Hie with the Pie
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3541 Accepted: 1846

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8
 
题意:给出一个有向图,最多的点数为11,求从点0出发,经过所有点之后,再回到点0的最短路径。
思路:先用floyd预处理每点的最短距离。之后可以全排列枚举点的访问顺序,取最小值。但是更快的做法是状压dp。dp[S][i]表示在状态S,最后到达i的最短距离。
 
AC代码:
#include <iostream>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <queue>
#include <stack>
#include <ctime>
#include <vector>
#include <algorithm>
#define ll long long
#define L(rt) (rt<<1)
#define R(rt)  (rt<<1|1)
#define eps 1e-6;
using namespace std;

const int INF = 1e9;
const int maxn = 11;

int G[maxn][maxn], dp[1<<maxn][maxn];   //dp[S][i]表示在状态S,最后到达i的最短距离
int n;
void floyd()
{
    for(int k = 0; k <= n; k++)
        for(int i = 0; i <= n; i++)
            for(int j = 0; j <= n; j++)
                if(G[i][j] > G[i][k] + G[k][j])
                    G[i][j] = G[i][k] + G[k][j];
}
void DP(){
    for(int S = 0; S < (1 << n); S++)
    for(int i = 1; i <= n; i++)
    if(S & (1 << (i - 1)))   //状态经过了i
    {
        if(S == (1 << (i - 1))) dp[S][i] = G[0][i];  //状态只经过i,即从0到i
        else
        {
            dp[S][i] = INF;
            for(int j = 1; j <= n; j++)            //经过j再到i
            if(i != j && S & (1 << (j - 1)))
            dp[S][i] = min(dp[S ^ (1 <<(i - 1))][j] + G[j][i],dp[S][i]);
        }
    }
    int ans = INF;
    for(int i = 1; i <= n; i++)
    if(dp[(1 << n) - 1][i] + G[i][0] < ans) ans = dp[(1 << n) - 1][i] + G[i][0];
    printf("%d\n", ans);
}
int main()
{
    while(scanf("%d", &n), n)
    {
        memset(G, 0, sizeof(G));
        for(int i = 0; i <= n; i++)
            for(int j = 0; j <= n; j++)
                scanf("%d", &G[i][j]);
        floyd();
        DP();
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值