poj 1644 To Bet or Not To Bet(递推)

7 篇文章 0 订阅
To Bet or Not To Bet
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1312 Accepted: 412

Description

Alexander Charles McMillan loves to gamble, and during his last trip to the casino he ran across a new game. It is played on a linear sequence of squares as shown below.

A chip is initially placed on the Start square. The player then tries to move the chip to the End square through a series of turns, at which point the game ends. In each turn a coin is fl
ipped: if the coin is heads the chip is moved one square to the right and if the coin is tails the chip is moved two squares to the right (unless the chip is one square away from the End square, in which case it just moves to the End square). At that point, any instruction on the square the coin lands on must be followed. Each instruction is one of the following:
1. Move right n squares (where n is some positive integer)
2. Move left n squares (where n is some positive integer)
3. Lose a turn
4. No instruction
After following the instruction, the turn ends and a new one begins. Note that the chip only follows the instruction on the square it lands on after the coin flip. If, for example, the chip lands on a square that instructs it to move 3 spaces to the left, the move is made, but the instruction on the resulting square is ignored and the turn ends. Gambling for this game proceeds as follows: given a board layout and an integer T, you must wager whether or not you think the game will end within T turns.
After losing his shirt and several other articles of clothing, Alexander has decided he needs professional help-not in beating his gambling addiction, but in writing a program to help decide how to bet in this game.

Input

Input will consist of multiple problem instances. The first line will consist of an integer n indicating the number of problem instances. Each instance will consist of two lines: the first will contain two integers m and T (1 <= m <= 50, 1 <= T <= 40), where m is the size of the board excluding the Start and End squares, and T is the target number of turns. The next line will contain instructions for each of the m interior squares on the board. Instructions for the squares will be separated by a single space, and a square instruction will be one of the following: +n, -n, L or 0 (the digit zero). The first indicates a right move of n squares, the second a left move of n squares, the third a lose-a-turn square, and the fourth indicates no instruction for the square. No right or left move will ever move you off the board.

Output

Output for each problem instance will consist of one line, either
Bet for. x.xxxx
if you think that there is a greater than 50% chance that the game will end in T or fewer turns, or
Bet against. x.xxxx
if you think there is a less than 50% chance that the game will end in T or fewer turns, or
Push. 0.5000
otherwise, where x.xxxx is the probability of the game ending in T or fewer turns rounded to 4 decimal places. (Note that due to rounding the calculated probability for display, a probability of 0.5000 may appear after the Bet for. or Bet against. message.)

Sample Input

5
4 4
0 0 0 0
3 3
0 -1 L
3 4
0 -1 L
3 5
0 -1 L
10 20
+1 0 0 -1 L L 0 +3 -7 0

Sample Output

Bet for. 0.9375
Bet against. 0.0000
Push. 0.5000
Bet for. 0.7500
Bet for. 0.8954
 
题意:有排线性排列的方格,有起点和终点方格,除了起点和终点,每个方格都有一个指令,每格可以抛一次硬币,当硬币正面朝上时向右走一格,反面朝上时向左走一格,这样抛硬币后走到另一个格子时,要执行格子中的指令,指令有4种:-n:向左走n格,+n:向右走n格,L:失去一次抛硬币的机会,0:没有指令,待在原地。
思路:设dp[i][j]走到第i格时所用的抛硬币次数为j次的概率。初始化dp[0][0]=1.0,然后递推下去。
 
AC代码:
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <iostream>

using namespace std;
const int INF=100000000;
int main()
{
   int m,t,n;
   int ins[60];     //保存每个格子的指令
   double dp[60][60];
   char str[5];
   cin>>n;
   while(n--)
   {
       cin>>m>>t;
       ins[0]=0;   //起点指令
       ins[m+1]=0;   //终点指令
       ins[m+2]=-1;   //超过终点时回到终点
       for(int i=1;i<=m;i++)
       if(scanf("%d",&ins[i])==0)
       {
           scanf("%s",str);
           ins[i]=INF;
       }
       memset(dp,0,sizeof(dp));
       dp[0][0]=1.0;
       for(int j=0;j<=t;j++)
       for(int i=0;i<=m;i++)
       {
           //抛一次硬币后,可能走一格,也可能走两格
           if(ins[i+1]==INF)       //若下一格指令为L,失去一次抛硬币机会,更新dp[i+1][j+2]
           dp[i+1][j+2]+=dp[i][j]*0.5;
           else
           dp[i+1+ins[i+1]][j+1]+=dp[i][j]*0.5;
           if(ins[i+2]==INF)      //若下两格指令为L,失去一次抛硬币机会,更新dp[i+2][j+2]
           dp[i+2][j+2]+=dp[i][j]*0.5;
           else
           dp[i+2+ins[i+2]][j+1]+=dp[i][j]*0.5;
       }
       for(int i=0;i<t;i++)
       dp[m+1][t]+=dp[m+1][i];
       if(dp[m+1][t]==0.5)
       printf("Push. 0.5000\n");
       else if(dp[m+1][t]>0.5)
       printf("Bet for. %.4f\n",dp[m+1][t]);
       else
       printf("Bet against. %.4f\n",dp[m+1][t]);
   }
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值