[PAT甲级]1016. Phone Bills (25)(统计用户每月电话账单)

1016. Phone Bills (25)

原题链接
A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word “on-line” or “off-line”.

For each test case, all dates will be within a single month. Each “on-line” record is paired with the chronologically next record for the same customer provided it is an “off-line” record. Any “on-line” records that are not paired with an “off-line” record are ignored, as are “off-line” records not paired with an “on-line” record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

题目大意:

  • 给出电话公司一个月的通话流水记录,统计各个用户每月的电话账单
  • 第一行给出每天每小时不同的收费, 按 分钟/美分 收费
  • 随后给出n行通话记录,客户名字name,时间mm:dd:hh:mm(月:日:时:分), 状态(接通时间on-line 挂断时间off-line)
  • 通话流水记录并不是全部都是有效的,每个人每段通话的on-line对应最近的off-line,多余的都是无效的
  • 最后按照要求输出每个人的月有效通话记录及其费用(按照美元计算,保留两位小数,1美元=100美分)

思路:

  • 做这道题完全参考了别人的想法,附上链接
  • 定义结构体,统计每条通话记录,其中time计算该通话时间距离每月1号凌晨的时间差,按照分钟计算,方便排序,同时避免计算跨天通话费用的麻烦
  • 先将给出的通话记录按照用户名字的先后顺序,用户时间的先后顺序排序
  • 然后筛选出有效的通话记录,map统计,每个用户对应一个数组,该数组记录其通话记录
  • 最后统计输出
  • 附上另一个链接,代码风格很棒

代码:

#include <iostream>
#include <vector>
#include <algorithm>
#include <map>
#include <cstdio>
using namespace std;
int rate[25];//通话 每分钟/美分
struct node{
    string name;//客户名字
    int month,day,hour,minute;//通话时间
    int time;//从01:00:00到当前的通话时长 方便排序 同时避免计算跨天通话费用的麻烦
    string status;//通话状态 接通on-line 挂断off-line
};
int cmp(node a, node b){
    return a.name!=b.name ? a.name<b.name : a.time<b.time;
}
double bill(node a, int *rate){
    double res = rate[24]*60*(a.day-1);
    for(int i=0; i<a.hour; i++)
        res += rate[i]*60;
    res += rate[a.hour]*a.minute;
    return res/100;//题目返回美元 计费则是每分钟/美分 所以除以100
}
int main()
{
    for(int i=0; i<24; i++){
        scanf("%d", &rate[i]);
        rate[24] += rate[i];
    }
    int n;
    scanf("%d", &n);
    vector<node> data(n);
    for(int i=0; i<n; i++){
        cin >> data[i].name;
        scanf("%d:%d:%d:%d", &data[i].month, &data[i].day, &data[i].hour, &data[i].minute);
        cin >> data[i].status;
        data[i].time = (data[i].day-1)*24*60 + data[i].hour*60 + data[i].minute;//从01:00:00到当前的通话时长
    }
    sort(data.begin(), data.end(), cmp);
    map<string, vector<node>> effective;//有效的通话记录 一人对应一个数组
    for(int i=1; i<n; i++){//筛选有效通话记录
        if(data[i].name==data[i-1].name && data[i-1].status=="on-line" && data[i].status=="off-line"){
            effective[data[i].name].push_back(data[i-1]);
            effective[data[i].name].push_back(data[i]);
        }
    }
    for(auto eff : effective){
        vector<node> temp = eff.second;//用户有效通话记录数组
        cout << eff.first;//输出用户名字
        printf(" %02d\n", temp[0].month);
        double total = 0.0;//总的通话费用
        for(int i=1; i<temp.size(); i+=2){
            double t = bill(temp[i], rate) - bill(temp[i-1], rate);//每段通话的费用
            printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n", temp[i-1].day, temp[i-1].hour, temp[i-1].minute, temp[i].day, temp[i].hour, temp[i].minute, temp[i].time-temp[i-1].time, t);
            total += t;
        }
        printf("Total amount: $%.2f\n", total);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值