[PAT甲级]1014. Waiting in Line (30)(银行排队办理业务结束时间 队列的应用)

1014. Waiting in Line (30)

原题链接
相似题目 1017. Queueing at Bank (25)
Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output “Sorry” instead.

Sample Input

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output

08:07
08:06
08:10
17:00
Sorry

题目大意:

  • 银行排队办理业务,有n个窗口,每个窗口前有黄线,黄线内最多排m个人,剩下的人在黄线外等候
  • 给出k个人,并给出他们办理业务所需要的时间time,查询p个人的办理业务结束时间,如果开始办理业务时超过了17:00,输出sorry
  • 08:00开始办理业务,17:00结束办理业务,如果业务已经开始办理,就继续办理直到办理业务结束窗口才关门。
  • 如果某个窗口有人办理业务结束,黄线外的人去那个窗口的队尾等候,如果两个窗口同时有人办理业务结束,就选择窗口号较小的

思路:

  • 这道题考察队列的应用
  • 设置结构体,包含队首的人出队(结束)时间poptime,队尾的人结束时间endtime,队列q包含队伍内每个人办理业务所需要的时间
  • 设置poptime,方便计算黄线外的何时能入队
  • 设置endtime,判断后面入队的人是否需要输出sorry
  • 数组result保存每个人结束时间,用分钟计算,最后输出转化为XX:XX比较方便
  • 数组sorry记录是否需要输出sorry
  • 先处理能够排进黄线内的人,再入队出队处理在黄线外等候的人

代码:

#include <iostream>
#include <cstdio>
#include <queue>
#include <vector>
using namespace std;
struct node{
    int poptime, endtime;//队首的人出队(结束)时间  队尾的人结束时间
    queue<int> q;
};
int main()
{
    //n个窗口(n<=20) m为黄线内最大容量(m<=10) k个顾客(k<=1000) q为要查询的顾客人数(q<=1000)
    int n, m, k, p, index=1;
    scanf("%d%d%d%d", &n, &m, &k, &p);
    vector<int> time(k+1), result(k+1);//顾客办理业务所需时间  顾客办理业务结束时间
    for(int i=1; i<=k; i++)
        scanf("%d", &time[i]);
    vector<node> window(n+1);//n个窗口n个队
    vector<bool> sorry(k+1, false);
    //处理开始就在黄线内顾客 前面m*n
    for(int i=1; i<=m; i++){
        for(int j=1; j<=n; j++){
            if(index <= k){
                window[j].q.push(time[index]);
                if(window[j].endtime >= 540)//队尾的人结束时间超过下午五点
                    sorry[index] = true;
                window[j].endtime += time[index];
                result[index] = window[j].endtime;
                index++;
            }
        }
    }
    //开始无法排进黄线内  m*n以后的人
    while(index <= k){
        int minPoptime=window[1].poptime, minWindow=1;
        for(int i=2; i<=n; i++){//寻找最先有人出来的窗口
            if(window[i].poptime < minPoptime){
                minPoptime = window[i].poptime;
                minWindow = i;
            }
        }
        window[minWindow].q.pop();//出队一个
        window[minWindow].q.push(time[index]);//入队
        window[minWindow].poptime += window[minWindow].q.front();//更新队首结束时间
        if(window[minWindow].endtime >= 540)
            sorry[index] = true;
        window[minWindow].endtime += time[index];//更新队尾结束时间
        result[index] = window[minWindow].endtime;//记录该顾客结束时间
        index++;
    }
    for(int i=1; i<=p; i++){
        int check;
        scanf("%d", &check);
        int temp = result[check];
        if(sorry[check] == true)
            printf("Sorry\n");
        else
            printf("%02d:%02d\n", (temp+480)/60, (temp+480)%60);//480 早上八点
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值