杭电2841 容斥定理求1到n之间和x互质的数的总数

           第一次写容斥定理,完全不懂啊,,,弱爆了。。。。。话说这道题最后就是判断横坐标和纵坐标两个值是否互质,如果互质则可以看到,否则看不到。题目:

Visible Trees

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 593    Accepted Submission(s): 225


Problem Description
There are many trees forming a m * n grid, the grid starts from (1,1). Farmer Sherlock is standing at (0,0) point. He wonders how many trees he can see.

If two trees and Sherlock are in one line, Farmer Sherlock can only see the tree nearest to him.
 

Input
The first line contains one integer t, represents the number of test cases. Then there are multiple test cases. For each test case there is one line containing two integers m and n(1 ≤ m, n ≤ 100000)
 

Output
For each test case output one line represents the number of trees Farmer Sherlock can see.
 

Sample Input
  
  
2 1 1 2 3
 

Sample Output
  
  
1 5
 

ac代码:

#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;
long long wid,len;
long long prime(long long x){
	vector<long long> ss;
	//先将x分解质因数
	for(long long i=2;i*i<=x;++i){
		if(x%i==0){
			ss.push_back(i);
			while(x%i==0)
				x/=i;
		}
	}
	if(x>1)  ss.push_back(x);
	//分解完毕
	long long count=0;
	//转化成二进制判断二进制中有多少个1
	for(long long i=1;i<(1<<ss.size());++i){
	   long long ones=0,mult=1;
	   for(long long j=0;j<ss.size();++j){
		   if(i&(1<<j)){//按位与运算,判断1的个数
		     ones++;
			 mult*=ss[j];
		   }
	   }
	   if(ones%2)  count+=(wid/mult);//(wid/mult)为其中有多少个数是mult的倍数,即不互质
	   else   count-=(wid/mult);
	}
	return wid-count;
}
int main(){
  int numcase;
  scanf("%d",&numcase);
  while(numcase--){
    long long sum=0;
	scanf("%lld%lld",&len,&wid);
	for(long long i=2;i<=len;++i){
	  sum+=(prime(i));
	}
	printf("%lld\n",sum+wid);
  }
  return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值