[Pick定理][三角剖分]Area

Area
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4385 Accepted: 1989

Description

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area. 

 
Figure 1: Example area. 

You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself. 

Input

The first line contains the number of scenarios. 
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy�of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units. 

Output

The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

Source



Pick定理:S = E/2 + I - 1

面积用三角剖分做,小心要把每个点换成绝对位置,因为计算面积需要。

边上的整点数等于GCD(dx,dy)+1,很容易证明。GCD有一个bug,就是a=0时返回b,b=0时返回a,这正好符合需要。注意每两条临边会有交点,所以不加1刚好。

#include <cstdio>
#include <cmath>
int n;
int x[110];
int y[110];

double calcS()
{
    double ans = 0;
    for (int i=0;i<n;i++)
    {
        ans += x[i]*y[i+1]-y[i]*x[i+1];
    }
    return fabs(ans)/2.0;
}

int gcd(int a,int b)
{
    while (b)
    {
        int tmp = b;
        b = a%b;
        a = tmp;
    }
    return a;
}

int abs(int a)
{
    if (a < 0) return -a;
    return a;
}

int calcE()
{
    int ans = 0;
    for (int i=1;i<=n;i++)
    {
        int xx = abs(x[i]-x[i-1]);
        int yy = abs(y[i]-y[i-1]);
        ans += gcd(xx,yy);
    }
    return ans;
}

int main()
{
    freopen("1265.in","r",stdin);
    freopen("1265.out","w",stdout);

    int T;
    scanf("%d",&T);

    for (int t=1;t<=T;t++)
    {
        scanf("%d",&n);
        x[0] = 0;
        y[0] = 0;
        for (int i=1;i<=n;i++)
        {
            scanf("%d%d",x+i,y+i);
            x[i] += x[i-1];
            y[i] += y[i-1];
        }


        double S = calcS();
        int E = calcE();
        int I = int(S+1-E/2.0);

        
        printf("Scenario #%d:\n%d %d %.1f\n\n",t,I,E,S);
    }


    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值