POJ3694 Network 无向图的桥

题目描述:

Description
A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can’t be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input
The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output
For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0 

Sample Output

Case 1:
1
0

Case 2:
2
0 

题目分析:

n个点,m条边的无向图,给q个询问,每个询问加一条边,求加入边后图的桥数量。
Tarjan算法和LCA算法。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
const int MAXN =100010;
const int MAXM =400010;
using namespace std;
int head[MAXN];
int tot,index;
int bridge;
int dfn[MAXN],low[MAXN],fa[MAXN],Dfn[MAXN];
bool cut[MAXN];
struct Edge
{
    int to,next;
}edge[MAXM];

void addedge(int u,int v)
{
    edge[tot].to=v;
    edge[tot].next=head[u];
    head[u]=tot++;
}
void init()
{
    memset(head,-1,sizeof(head));
    memset(dfn,0,sizeof(dfn));
    memset(dfn,0,sizeof(dfn));
    memset(cut,0,sizeof(cut));
    fa[1]=1,dfn[0]=0;
    tot=bridge=index=0;
}
void tarjan(int u,int pre)
{
    dfn[u]=low[u]=++index;
    Dfn[u]=Dfn[pre]+1;
    for(int i=head[u]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].to;
        if(v==pre) continue;
        if(!dfn[v])
        {
            fa[v]=u;
            tarjan(v,u);
            low[u]=min(low[u],low[v]);
            if(low[v]>dfn[u])
            {
                cut[v]=1;
                bridge++;
            }
        }
        else
            low[u]=min(low[u],dfn[v]);
    }
}
void LCA(int u,int v)
{
    if(Dfn[u]<Dfn[v]) swap(u,v);
    while(Dfn[u]>Dfn[v])
    {
        if(cut[u])
        {
            bridge--;
            cut[u]=false;
        }
        u=fa[u];
    }
    while(u!=v)
    {
        if(cut[u])
        {
            bridge--;
            cut[u]=false;
        }
        if(cut[v])
        {
            bridge--;
            cut[v]=false;
        }
        u=fa[u],v=fa[v];
    }
}
int n,m,q;
int main()
{
    int cas=0;
    while(~scanf("%d%d",&n,&m) && (n||m))
    {
        init();
        for(int i=1; i<=m; i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            addedge(u,v);
            addedge(v,u);
        }
        tarjan(1,0);
        scanf("%d",&q);
        printf("Case %d:\n",++cas);
        for(int i=1; i<=q; i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            LCA(u,v);
            printf("%d\n",bridge);
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值