安装glib提示pcre版本太低

原创 2016年08月29日 13:05:09

Linux 64bits 安装glib时提示需要pcre,通过yum安装后,glib提示版本太低,但下载最新版本安装后,仍然提示该问题。


后解决,系统默认到/usr/lib64下查找,因此只查到了低版本,为了解决该问题,需要在编译时指定lib目录。

./configure --prefix=/usr --docdir=/usr/share/doc/pcre-8.39 --libdir=/usr/lib64 --enable-unicode-properties --enable-pcre16 --enable-pcre32 --enable-pcregrep-libz --enable-pcregrep-libbz2 --enable-pcretest-libreadline --disable-static --enable-utf8


版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

Centos6.5下安装glib遇到的问题和常用解决方法

最近想给自己的Centos6.5安装gftp,上网查了一些教程,也查了一下官方文档,(官方文档有兴趣的可以到这里查看,不过是全英文的:https://www.gftp.org/faq.html#AEN...

Windows上面编译pcre的步骤

源码下载本文以8.35为例,其他的版本操作方法都是类似的。8.35版本的源代码参考链接: http://download.csdn.net/detail/u013344915/7793027当然,也...

Nginx+pcre部署及配置步骤

安装 在 Linux 下安装 Nginx     为了确保能在 Nginx 中使用正则表达式进行更灵活的配置,安装之前需要确定系统是否安装有 PCRE(Perl Compatible Regula...

tornado系列二:模板

1、在模板中使用占位符    在模板中,使用 {{占位符 }} 来表示要填充的内容,其中的占位符在模板调用时定义并进行实际的填充,例如:    Poem Maker Pro ...
  • midion9
  • midion9
  • 2016年05月04日 15:55
  • 367

tornado的mysql数据库操作

torndb是一个轻量级的基于MySQLdb封装的一个模块,从tornado3.0版本以后,其已经作为一个独立模块发行了。torndb依赖于MySQLdb模块,因此,在使用torndb模块时,要保证系...
  • midion9
  • midion9
  • 2016年05月05日 14:52
  • 2032

网页弹框I6版本太低提示下载

  • 2011年11月26日 21:24
  • 13KB
  • 下载

【linux】提醒"libc.so.6: version `GLIBC_2.14' not found"系统的glibc版本太低

http://www.myexception.cn/linux-unix/1622052.html

商家QQ在线状态按钮版本太低,不能发起会话,请按如下方法操作

商家QQ在线状态按钮版本太低,不能发起会话,请商家按如下方法操作: 方法一:请登录http://wp.qq.com/ 选择代码类型,点击完全公开,并确认页面上方...

录音声音太低设置

  • 2013年11月17日 01:23
  • 10KB
  • 下载
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:安装glib提示pcre版本太低
举报原因:
原因补充:

(最多只允许输入30个字)