02-线性结构2. Reversing Linked List (25)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

反转节点;我要学一下printf,scanf。。。dyx~
#include<iostream>
#include<algorithm>
#include<vector>
#include<iomanip>
using namespace std;
const int Max=100009;
class Node
{
    public:
    int add;
    int data;
    int  Next;
};
Node node[Max];
int main()
{
    int firstadd,num,k;
    cin>>firstadd>>num>>k;//k是反转节点;
    //输入数据;
    for(int i=1;i<=num;i++)
    {
        Node wyx;
        cin>>wyx.add>>wyx.data>>wyx.Next;
        node[wyx.add]=wyx;
    }
    //建立向量;
    vector <Node> dyx;
    //将数据压入向量当中;
    int first=firstadd;
    while(first!=-1)
    {
        dyx.push_back(node[first]);
        first=node[first].Next;
    }
    int len=dyx.size();
    int rev=len/k;//看有几节反转点;
    for(int i=1;i<=rev;i++)
    {
        int st=(i-1)*k;
        int end=i*k;
        reverse(dyx.begin()+st,dyx.begin()+end);
    }
        for(int i=0;i<len-1;i++)
        {
            cout<<setw(5)<<setfill('0')<<dyx[i].add<<" ";
            cout<<dyx[i].data<<" ";
            cout<<setw(5)<<setfill('0')<<dyx[i+1].add<<endl;
        }
        cout<<setw(5)<<setfill('0')<<dyx[len-1].add<<" ";
        cout<<dyx[len-1].data<<" ";
        cout<<-1<<endl;
        return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值