02-线性结构3 Reversing Linked List (25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→16→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (N≤10e5) which is the total number of nodes, and a positive K (K≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
先说一下注意点:
1、注意是每隔K个元素翻转一次,不足K个元素则按原序输出。如4→3→2→1→5→6
2、题目给的测试例子是每个节点都有用到,而测试点中有些节点是没有用到的,所以要先找到在同一条链表的节点。
再说一下思路:
建立一个结构体Node,存放address、data、next;另外我还增加了一个number,后面用来排序;排完序开始翻转,就是怎么输出的问题了,直接上代码!

#include<bits/stdc++.h>
#include<algorithm>
#define max 100005
using namespace std;
struct Node
{
	int number;
	int addresss;
	int data;
	int next_add;
}a[max];
bool cmp(Node x,Node y)
{
	return x.number<y.number;
}
int main()
{
	int first,N,K;
	cin>>first>>N>>K;
	int i=0,j,add;
	for(i=0;i<max;i++){
		a[i].number=max;
	}
	for(i=0;i<N;i++){
		cin>>add;
		cin>>a[add].data>>a[add].next_add;
		a[add].addresss=add;
	}
	int num=0;
	for(i=first;i!=-1;i=a[i].next_add) {
		a[i].number=num;
		num++;
	} 
	sort(a,a+max,cmp);
	int total=num/K;
	for(j=1;j<=total;j++)//核心部分
	{
		if(j==1){
			printf("%05d %d ",a[K*j-1].addresss,a[K*j-1].data);
			for(i=K*j-2;i>=K*(j-1);i--)
			   printf("%05d\n%05d %d ",a[i].addresss,a[i].addresss,a[i].data);
		}
		else{
			for(i=K*j-1;i>=K*(j-1);i--)
				printf("%05d\n%05d %d ",a[i].addresss,a[i].addresss,a[i].data);
		}
	}
	j--;
    if(num%K!=0) {//剩下的元素不足K个则按原先的顺序输出;
		for(i=K*j;i<num;i++)
			printf("%05d\n%05d %d ",a[i].addresss,a[i].addresss,a[i].data);
	}
	printf("-1\n");
	return 0;
} 

以下是测试结果,时间蛮久的!全AC真的舒服!!
在这里插入图片描述

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值