POJ 3278 Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题意:有一个农民和一头牛,他们在一个数轴上,牛在k位置保持不动,农户开始时在n位置。设农户当前在M位置,每次移动时有三种选择:1.移动到M-1;2.移动到M+1位置;3.移动到M*2的位置。问最少移动多少次可以移动到牛所在的位置。
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=100005;
int a[maxn],time[maxn];
int i,j,k,m,n;
bool pd(int x){
	if(x<0 || x>maxn || time[x]!=0)
		return 0;
	else 
		return 1;
}
int bfs(int n,int k){
	if(n==k)return 0;
	int x,f=0,l=0;
	a[f]=n;
	f++;
	while(f>l){
		x=a[l];
		l++;
		if(x+1==k || x-1==k || x*2==k)
			return time[x]+1;
		if(pd(x+1)==1){
			time[x+1]=time[x]+1;
			a[f]=x+1;
			f++;
		}
		if(pd(x-1)==1){
			time[x-1]=time[x]+1;
			a[f]=x-1;
			f++;
		}
		if(pd(x*2)==1){
			time[x*2]=time[x]+1;
			a[f]=x*2;
			f++;
		}
	}
}
int main(){
	cin>>n>>k;
	cout<<bfs(n,k);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值