POJ 2075 Tangled in Cables

Description

You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.

Input

Only one town will be given in an input.
  • The first line gives the length of cable on the spool as a real number.
  • The second line contains the number of houses, N
  • The next N lines give the name of each house's owner. Each name consists of up to 20 characters {a–z,A–Z,0–9} and contains no whitespace or punctuation.
  • Next line: M, number of paths between houses
  • next M lines in the form

< house name A > < house name B > < distance >
Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.

Output

The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output
Not enough cable
If there is enough cable, then output
Need < X > miles of cable
Print X to the nearest tenth of a mile (0.1).

Sample Input

100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0

Sample Output

Need 10.2 miles of cable
题目大意:给一个总线长,和n个人,m组关系,表示两个人之间的距离,现在要求所有人之间都连通,问最少需要多长的线,若超过总长,则输出Not enough cable


裸最小生成树

我用prim写的

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<map>
#include<string>
#define Size 1010
using namespace std;
map <string,int> people;//string -> int 的映射 
string name1,name2;
const double inf=999999999.0;
const int INF=999999999;
double a[Size][Size];
double dist[Size];
double length;
int p[Size];
int k,m,n;
void prim(){
	double sum=0;
	double MIN;
	int k;
	int num=0;
	for(int i=1;i<=n;i++)
		dist[i]=inf;
	memset(p,0,sizeof(p));
	dist[1]=0;
	while(num<n){
		num++;
		MIN=inf;
		for(int j=1;j<=n;j++){
			if(!p[j] && dist[j]<MIN){
				MIN=dist[j];
				k=j;
			}
		}
		if(MIN!=inf)	sum+=MIN;
		p[k]=1;
		for(int j=1;j<=n;j++){
			if(!p[j] && a[k][j] && a[k][j]<dist[j]){
				dist[j]=a[k][j];
			}
		}
	}
	if(sum>length) printf("Not enough cable\n");
	else printf("Need %.1f miles of cable\n",sum);
	return ;
}
int main(){
	int i,j;
	scanf("%lf",&length);
	scanf("%d",&n);
	for(i=1;i<=n;i++){
		cin>>name1;
		people[name1]=i;
	}
	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
			a[i][j]=inf;
	scanf("%d",&m);
	for(i=1;i<=m;i++){
		double d;
		cin>>name1;
		cin>>name2;
		scanf("%lf",&d);
		a[people[name1]][people[name2]]=d;
		a[people[name2]][people[name1]]=d;
	}
	prim();
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值