POJ 2689 Prime Distance

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

题目大意:给出一个区间[L,U],找出区间内,相邻距离最近的两个素数 和 相邻距离最远的两个素数。

1<=L<U<=2,147,483,647 区间长度不超过1,000,000。

即就是要筛选出[L,U]之间的素数

 

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#define MAX 50000+10
#define inf 999999999
using namespace std;
bool prime[60010];//WA在这里···60000防爆 
long long primes[60010],cnt;//1~50000的素数 
long long primess[1000000+10];
int maxn,minn;
void make_prime(){
	int k=(int)sqrt(MAX);
	for(int i=2;i<=k;i++){
		if(prime[i])continue;
		for(int j=i*i;j<=MAX;j+=i)
			prime[j]=1;
	}
	for(int i=2;i<=MAX;i++)
	if(!prime[i])primes[++cnt]=i;
}
long long start1,end1,start2,end2;
int main(){
	make_prime();
	long long m,n;
	while(scanf("%lld%lld",&m,&n)!=EOF){// EOF防止TLE 
		if(m==1)m=2;
		maxn=-inf;
		minn=inf;
		memset(primess,0,sizeof(primess));
		//映射 小数=每个大数-m
		for(long long i=1;i<=cnt;i++){//枚举每个小素数 
			long long l,r;
			if(m%primes[i]==0)l=m/primes[i];//找出倍数 
			else l=m/primes[i]+1;
			r=n/primes[i];
			for(long long j=l;j<=r;j++)
				if(j>1)primess[primes[i]*j-m]=1;//筛选大合数 
		}
		long long sum=-1;//数组从0开始存 
		for(long long i=m;i<=n;i++)
			if(primess[i-m]==0)primess[++sum]=i;
		if(sum<1){
			printf("There are no adjacent primes.\n");
			continue;
		}
		for(int i=0;i<sum;i++){
			long long k=primess[i+1]-primess[i];
			if(k<minn){
				minn=k;
				start1=primess[i];
				end1=primess[i+1];
			}
			if(k>maxn){
				maxn=k;
				start2=primess[i];
				end2=primess[i+1];
			}
		}
		printf("%lld,%lld are closest, %lld,%lld are most distant.\n",start1,end1,start2,end2);
	}
	return 0;
}

下面这个代码更简洁

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<algorithm>

using namespace std;

typedef long long LL;

typedef unsigned long long uLL;

#define REP(i, a, b) for(register int i = (a), i##_end_ = (b); i <= i##_end_; ++ i)
#define DREP(i, a, b) for(register int i = (a), i##_end_ = (b); i >= i##_end_; -- i)
#define EREP(i, a) for(register int i = (be[a]); i != -1; i = nxt[i])
#define debug(...) fprintf(stderr, __VA_ARGS__)
#define mem(a, b) memset((a), b, sizeof(a))

template<typename T> inline bool chkmin(T &a, const T &b) { return a > b ? a = b, 1 : 0; }
template<typename T> inline bool chkmax(T &a, const T &b) { return a < b ? a = b, 1 : 0; }

template <class T>
T read(T sum = 0, T fg = 0)
{
	char c = getchar();
	while(c < '0' || c > '9') { fg |= c == '-'; c = getchar(); }
	while(c >= '0' && c <= '9') { sum = sum * 10 + c - '0'; c = getchar(); }
	return fg ? -sum : sum;
}

const int inf = 1e9;

const LL INF = 1e17;

const int Size = 1000010;

const int maxn = 1 << 16;

bool isnotprime[maxn];

int prime[Size], prime_cnt = 0;

void get_prime()
{
	isnotprime[0] = isnotprime[1] = 1;
	REP(i, 2, maxn - 1)
	{
		if(!isnotprime[i]) prime[++prime_cnt] = i;
		for(int j = 1; j <= prime_cnt && i * prime[j] < maxn; ++j)
		{
			isnotprime[i * prime[j]] = 1;
			if(i % prime[j] == 0) break;
		}
	}
}

int L, R;
bool vis[Size];
int num[Size], cnt;

void work()
{
	mem(vis, 0);
	if(L == 1) vis[0] = 1;
	REP(i, 1, prime_cnt)
	{
		REP(j, L / prime[i], R / prime[i])
		{
			if(prime[i] * j - L < 0) continue;
			if(j > 1) vis[prime[i] * j - L] = 1;
		}
	}
	cnt = 0;
	REP(i, 0, R - L) if(!vis[i]) num[++cnt] = i + L;
	int MAX = -inf, MIN = inf, x1, y1, x2, y2;
	REP(i, 2, cnt)
	{
		int tmp = num[i] - num[i - 1];
		if(chkmin(MIN, tmp)) x1 = num[i - 1], y1 = num[i];
		if(chkmax(MAX, tmp)) x2 = num[i - 1], y2 = num[i];
	}
	if(MIN == inf) printf("There are no adjacent primes.\n");
	else printf("%d,%d are closest, %d,%d are most distant.\n", x1, y1, x2, y2);
}

int main()
{
#ifndef ONLINE_JUDGE
	freopen("input.in", "r", stdin);
	freopen("output.out", "w", stdout);
#endif
	get_prime();
	while(scanf("%d%d", &L, &R) != EOF) work();
	return 0;
}

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值