1028. List Sorting (25)【排序】——PAT (Advanced Level) Practise

题目信息

1028. List Sorting (25)

时间限制200 ms
内存限制65536 kB
代码长度限制16000 B

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

解题思路

排序

AC代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node{
    char name[10];
    int id, score;
}lst[100005];
bool cmp1(const node& a, const node& b){
    return a.id < b.id;
}
bool cmp2(const node& a, const node& b){
    int t = strcmp(a.name, b.name);
    if (t == 0) return a.id < b.id;
    return 0 > t;
}
bool cmp3(const node& a, const node& b){
    if (a.score == b.score) return a.id < b.id;
    return a.score < b.score;
}
int main()
{
    int n, k;
    char name[10];
    int id, score;
    scanf("%d%d", &n, &k);
    for (int i = 0; i < n; ++i){
        scanf("%d%s%d", &lst[i].id, lst[i].name, &lst[i].score);
    }
    if (k == 1) sort(lst, lst + n, cmp1);
    if (k == 2) sort(lst, lst + n, cmp2);
    if (k == 3) sort(lst, lst + n, cmp3);
    for (int i = 0; i < n; ++i){
        printf("%06d %s %d\n", lst[i].id, lst[i].name, lst[i].score);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Java中的List接口提供了许多排序方法,其中最常用的是Collections.sort()方法。以下是使用Collections.sort()方法对List进行排序的示例代码: ``` import java.util.ArrayList; import java.util.Collections; import java.util.List; public class SortListExample { public static void main(String[] args) { List<String> list = new ArrayList<>(); list.add("apple"); list.add("banana"); list.add("orange"); list.add("grape"); System.out.println("Before sorting: " + list); Collections.sort(list); System.out.println("After sorting: " + list); } } ``` 输出: ``` Before sorting: [apple, banana, orange, grape] After sorting: [apple, banana, grape, orange] ``` 通过调用Collections.sort()方法,List中的元素按字母顺序进行排序。 另外,Java 8也引入了Stream API,可以使用它来排序List。以下是使用Stream API对List进行排序的示例代码: ``` import java.util.ArrayList; import java.util.List; public class SortListExample { public static void main(String[] args) { List<String> list = new ArrayList<>(); list.add("apple"); list.add("banana"); list.add("orange"); list.add("grape"); System.out.println("Before sorting: " + list); list = list.stream().sorted().collect(Collectors.toList()); System.out.println("After sorting: " + list); } } ``` 输出: ``` Before sorting: [apple, banana, orange, grape] After sorting: [apple, banana, grape, orange] ``` 通过调用stream().sorted()方法,List中的元素按字母顺序进行排序。最后,使用collect()方法将排序后的元素收集到一个新的List中。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值