【PAT(甲级)】1028 List Sorting(有易错的测试点分析)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 9

Sample Output 3:

000002 James 9
000001 Zoe 60
000007 James 85
000010 Amy 90

解题思路:

自定义一个结构来存储学生的基本信息(学生ID,学生姓名,学生成绩),然后按照题意自定义3种不同的排序方式。对数组进行排序即可。对于ID的升序排序,其实可以用string来存储ID,然后直接比较即可,这样比int会方便很多,不需要前补0。

对于C的不同,可以用switch-case的方式来决定不同的C的不同处理方式。

易错点:

1. 测试点2,3是对C等于2,3时的处理,分别针对姓名和成绩的非降序排序;

2. 当姓名或者成绩相同时,按照学生ID的升序进行排序。

代码:

#include<bits/stdc++.h>
using namespace std;
typedef struct Student{
	string ID;
	string name;
	int grade;
};

//按照学生ID的升序排序 
bool cmp1(Student a,Student b){
	return a.ID<b.ID;
}

//按照学生姓名非降序排序 
bool cmp2(Student a,Student b){
	if(a.name==b.name){
		//当姓名相同时,按照ID升序排序 
		return cmp1(a,b);
	}
	return a.name<b.name;
}


//按照学生成绩非降序排序 
bool cmp3(Student a,Student b){
	if(a.grade==b.grade){
		//当成绩相同时,按照ID升序排序 
		return cmp1(a,b);
	}
	return a.grade<b.grade;
}

int main(){
	int N,C;
	cin>>N>>C;
	Student st[N];
	for(int i=0;i<N;i++){
		cin>>st[i].ID>>st[i].name>>st[i].grade;
	}
	//switch-case的方式进行分类,讨论按照C是什么排序 
	switch (C){
		case 1: sort(st,st+N,cmp1);break;
		case 2: sort(st,st+N,cmp2);break;
		case 3: sort(st,st+N,cmp3);break;
	}
	for(int i=0;i<N;i++){
		cout<<st[i].ID<<" "<<st[i].name<<" "<<st[i].grade<<endl;
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值