NWERC 2007 / UVa 12124 Assemble (二分搜索&最小值最大问题)

12124 - Assemble

Time limit: 3.000 seconds

Recently your team noticed that the computer you use to practice for programming contests is not good enough anymore. Therefore, you decide to buy a new computer.

To make the ideal computer for your needs, you decide to buy separate components and assemble the computer yourself. You need to buy exactly one of each type of component.

The problem is which components to buy. As you all know, the quality of a computer is equal to the quality of its weakest component. Therefore, you want to maximize the quality of the component with the lowest quality, while not exceeding your budget.

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

  • One line with two integers: 1 ≤ n ≤ 1000, the number of available components and 1 ≤b ≤ 1000000000, your budget.

  • n lines in the following format: ``type name price quality'', wheretype is a string with the type of the component, name is a string with the unique name of the component,price is an integer (0 ≤ price < 1000000) which represents the price of the component andquality is an integer (0 ≤ quality ≤ 1000000000) which represents the quality of the component (higher is better). The strings contain only letters, digits and underscores and have a maximal length of 20 characters.

It will always possible to construct a computer with your budget.

Output

Per testcase:

  • One line with one integer: the maximal possible quality.

Sample Input

1
18 800
processor 3500_MHz 66 5
processor 4200_MHz 103 7
processor 5000_MHz 156 9
processor 6000_MHz 219 12
memory 1_GB 35 3
memory 2_GB 88 6
memory 4_GB 170 12
mainbord all_onboard 52 10
harddisk 250_GB 54 10
harddisk 500_FB 99 12
casing midi 36 10
monitor 17_inch 157 5
monitor 19_inch 175 7
monitor 20_inch 210 9
monitor 22_inch 293 12
mouse cordless_optical 18 12
mouse microsoft 30 9
keyboard office 4 10

Sample Output

9

思路:解决“最小值最大”的常用方法就是二分答案。假设答案为x,那么删除品质小于x的所有配件,如果能组装出一台电脑,那么正确答案ans>=x,否则ans<x。

#include <cstdio>
#include <string>
#include <vector>
#include <map>  //C++中map容器提供一个键值对容器,键本身是不能被修改的,除非删除
using namespace std;

int cnt;	//组件的类型数
map<string, int> id;
int ID(string s){
	if(!id.count(s)){	//使用count,返回的是被查找元素的个数。如果有,返回1;否则,返回0。注意,map中不存在相同元素,所以返回值只能是1或0。
		id[s] = cnt++;
	}
	return id[s];
} 
const int maxn = 1000 + 5;
struct Component{
	int price;
	int quality;
};
int n, b; 	//组件的数目和预算
vector<Component> comp[maxn];

bool ok(int q){
	int sum = 0;
	
	for(int i = 0; i < cnt; i++){
		int cheapest = b + 1, m = comp[i].size();
		for(int j = 0; j < m; j++){
			if(comp[i][j].quality >= q) cheapest = min(cheapest, comp[i][j].price);
		}
			if(cheapest == b + 1){
				return false;
			}
			sum += cheapest;
			if(sum > b){
				return false;
			}
		
	}

	return true;
} 

int main(){
	freopen("题.txt", "r", stdin);
	int T;
	scanf("%d", &T);
	while(T--){
		scanf("%d%d", &n, &b);
		cnt = 0;
		for(int i = 0; i < n; i++){
			comp[i].clear();
		}
		id.clear();
		int maxq = 0;
		for(int i = 0; i < n; i++){
			char type[30], name[30];
			int p, q;
			scanf("%s%s%d%d", type, name, &p, &q);
			maxq = max(maxq, q);
			comp[ID(type)].push_back((Component){p, q});
		}
		int L = 0, R = maxq;
		while(L < R){
			
			int M = L + (R - L + 1) /2;
		
			if(ok(M)){
				L = M;
				
			}else{
					R = M - 1;
			}
		}
		printf("%d\n", L);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值