UVA 12124 - Assemble(二分答案)

Problem A - Assemble

Time limit: 2 seconds

Recently your team noticed that the computer you use to practice for programming contests is not good enough anymore. Therefore, you decide to buy a new computer.

To make the ideal computer for your needs, you decide to buy separate components and assemble the computer yourself. You need to buy exactly one of each type of component.

The problem is which components to buy. As you all know, the quality of a computer is equal to the quality of its weakest component. Therefore, you want to maximize the quality of the component with the lowest quality, while not exceeding your budget.

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

  • One line with two integers: 1 ≤ n ≤ 1000, the number of available components and 1 ≤ b ≤ 1000000000, your budget.
  • n lines in the following format: ``type name price quality'', where type is a string with the type of the component, name is a string with the unique name of the component, price is an integer (0 ≤ price < 1000000) which represents the price of the component and quality is an integer (0 ≤ quality ≤ 1000000000) which represents the quality of the component (higher is better). The strings contain only letters, digits and underscores and have a maximal length of 20 characters.

It will always possible to construct a computer with your budget.

Output

Per testcase:

  • One line with one integer: the maximal possible quality.

Sample Input

1
18 800
processor 3500_MHz 66 5
processor 4200_MHz 103 7
processor 5000_MHz 156 9
processor 6000_MHz 219 12
memory 1_GB 35 3
memory 2_GB 88 6
memory 4_GB 170 12
mainbord all_onboard 52 10
harddisk 250_GB 54 10
harddisk 500_FB 99 12
casing midi 36 10
monitor 17_inch 157 5
monitor 19_inch 175 7
monitor 20_inch 210 9
monitor 22_inch 293 12
mouse cordless_optical 18 12
mouse microsoft 30 9
keyboard office 4 10

Sample Output

9

                                                                    

题意:

有钱B(1 ≤B≤ 1000000000), 组装一台电脑,给出n(1 ≤ n ≤ 1000)组数据,包括零件名,名字,价钱,质量。求出在预算范围内质量最差的零件质量值, 要使得这个值越大越好。

思路:

解决“最小值最大”问题的常用方法是二分答案。有两种二分答案的写法,应该是使用取下界的写法。

CODE:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;

struct node
{
    int p, q;
}n[1005][1005];
int dnum[1005];
int N, B, cnt;
char t[25];
map<string, int> m;

bool cmp(node a, node b)
{
    return a.p < b.p;
}

bool ok(int Q)
{
    int sum = 0, j;
    for(int i = 1; i < cnt; i++){
        for(j = 0; j < dnum[i]; j++){
            if(n[i][j].q >= Q && sum + n[i][j].p <= B){
                sum += n[i][j].p;
                break;
            }
        }
        if(j == dnum[i]) return false;
    }
    return true;
}
int init()
{
   cnt = 1;
   int maxq = 0;
   m.clear();
   memset(dnum, 0, sizeof(dnum));
   memset(n, 0, sizeof(n));

   for(int i = 0; i < N; i++){
        int p, q;
        scanf("%s %*s %d %d", t, &p, &q);
        if(m[t] == 0){
            m[t] = cnt++;
            n[m[t]][dnum[m[t]]].p = p;
            n[m[t]][dnum[m[t]]++].q = q;
        }
        else{
            n[m[t]][dnum[m[t]]].p = p;
            n[m[t]][dnum[m[t]]++].q = q;
        }
        maxq = max(maxq, q);
    }

    for(int i = 1; i < cnt; i ++){
        sort(n[i], n[i] + dnum[i], cmp);
    }
    return maxq;
}
int main()
{
    //freopen("in", "r", stdin);
    int T;
    scanf("%d", &T);
    while(T --){
       scanf("%d %d", &N, &B);

        int l = 0, r = init();
        while(l < r){
            int mid = l + (r - l +1) / 2;
            if(ok(mid)){
                l = mid;
            }
            else r = mid - 1;
        }
        printf("%d\n", l);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值