poj-3258 River Hopscotch

题目链接:http://poj.org/problem?id=3258

River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3829 Accepted: 1649

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to Mrocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set ofM rocks.

Input

Line 1: Three space-separated integers:  LN, and  M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
题意:相当于一个数标轴,以0点位起点,输入终点位置L,0-L中的石子块数n,以及要移走的石子块数m;n块石子的坐标会给出;
求(移走m块石子后的每相邻两块石子距离的最大值)的最小值。
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
	int l,n,m;
	while(cin>>l>>n>>m)
	{
		int i;
		int* rock=new int[n+2];   //动态数组。 n个石子以及起始终点共(n+2)个
		rock[n+1]=l;
		rock[0]=0;
		int min=l,max=l,mid;      //max表示一步的最大距离
		for(i=1;i<=n+1;i++)
		{
			if(i<n+1)
				cin>>rock[i];
			if(rock[i]-rock[i-1]<min)
				min=rock[i]-rock[i-1];     //min:一步的最短距离
		}
		sort(rock,rock+(n+2));   //对石子排序
		while(min<=max)
		{
			mid=(min+max)/2;
			int sum=0;
			int delrock=0;     //清除的石子的数目
			for(i=1;i<=n+1;i++)
			{
				if((sum+=rock[i]-rock[i-1]) <=mid)      //sum来表示一段累计的距离,当sum>mid时,作为一段,sum清零重置
					delrock++;
				else
					sum=0;
			}
			if(delrock<=m)      //清除石子数目不大于m(即使等于m也不一定为最优解),下界需增大;否则上界需减小
				min=mid+1;      //  不是min=mid!
			else
				max=mid-1;
		}
		cout<<min<<endl;
	}
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值