hdu1002(高精度)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 181565    Accepted Submission(s): 34671


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 

Recommend

We have carefully selected several similar problems for you:  1063 1316 1007 1133 2064 

      本题较简单。涉及到大数相加,可用字符串朱未处理,也可用Java 大叔类。

 

1.Java大数类

import java.math.BigInteger;
import java.util.Scanner;


public class hdu1002 {
	static Scanner input=new Scanner(System.in);
	public static void main(String[] str)
	{
		while(input.hasNext())
		{
			int tag=1;
			int i=0;
			int m=input.nextInt();
			BigInteger a,b,c;
			while(i<m)
			{
				a=input.nextBigInteger();
				b=input.nextBigInteger();
				c=a.add(b);
				System.out.println("Case "+(tag++)+":");
				System.out.println(a+" + "+b+" = "+c);
			}
		}
	}

}


2.C++用字符串写

#include <stdio.h>
#include <string.h>
#define MAXLEN 1001

int my_max(int a, int b)
{
    return a > b? a : b;
}

void revert_string(const char *in, char *out)
{
    int n = strlen(in);
    while (n-- > 0) {
        *out++ = in[n];
    }
    *out=0;
}

void *do_int_add(char *sa, char *sb, char *out)
{
    int shift;
    int salen = strlen(sa);
    int sblen = strlen(sb);
    int i, n;
    
    n = my_max(salen, sblen);
    
    if (salen < sblen) {
        while (salen < sblen) {
            sa[salen++] = '0';
        }
        sa[salen] = 0;
    } else {
        while (sblen < salen) {
            sb[sblen++] = '0';
        }
        sb[sblen] = 0;
    }

    shift = 0;
    for (i=0; i<n; i++) {
        int sum = sa[i] - '0' + sb[i] - '0' + shift;
        out[i] = (sum % 10) + '0';
        shift = sum >= 10 ? 1:0;
    }
    
    if (shift) {
        out[i] = '1';
        out[i+1] = 0;
    } else {
        out[i] = 0;
    }
}

void int_add(char *sa, char *sb, char *out)
{
    char rsa[MAXLEN], rsb[MAXLEN], rout[MAXLEN];
    revert_string(sa, rsa);
    revert_string(sb, rsb);
    do_int_add(rsa, rsb, rout);
    revert_string(rout, out);
}

int main()
{
    char a[MAXLEN], b[MAXLEN], out[MAXLEN];
    int i, n;

    scanf("%d", &n);
    
    if (n<1 || n>20)
        return 0;

    for (i=0; i<n; i++) {
        scanf("%s", a);
        scanf("%s", b);
        int_add(a, b, out);
        printf("Case %d:\n", i+1);
        printf("%s + %s = %s\n", a, b, out);
        if (i+1<n)
            printf("\n");
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值