HDU1708(斐波那契数列)

Fibonacci String

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2406    Accepted Submission(s): 825


Problem Description
After little Jim learned Fibonacci Number in the class , he was very interest in it.
Now he is thinking about a new thing -- Fibonacci String .

He defines : str[n] = str[n-1] + str[n-2] ( n > 1 )

He is so crazying that if someone gives him two strings str[0] and str[1], he will calculate the str[2],str[3],str[4] , str[5]....

For example :
If str[0] = "ab"; str[1] = "bc";
he will get the result , str[2]="abbc", str[3]="bcabbc" , str[4]="abbcbcabbc" …………;

As the string is too long ,Jim can't write down all the strings in paper. So he just want to know how many times each letter appears in Kth Fibonacci String . Can you help him ?
 


 

Input
The first line contains a integer N which indicates the number of test cases.
Then N cases follow.
In each case,there are two strings str[0], str[1] and a integer K (0 <= K < 50) which are separated by a blank.
The string in the input will only contains less than 30 low-case letters.
 


 

Output
For each case,you should count how many times each letter appears in the Kth Fibonacci String and print out them in the format "X:N".
If you still have some questions, look the sample output carefully.
Please output a blank line after each test case.

To make the problem easier, you can assume the result will in the range of int.
 


 

Sample Input
  
  
1 ab bc 3
 


 

Sample Output
  
  
a:1 b:3 c:2 d:0 e:0 f:0 g:0 h:0 i:0 j:0 k:0 l:0 m:0 n:0 o:0 p:0 q:0 r:0 s:0 t:0 u:0 v:0 w:0 x:0 y:0 z:0

 

科波菲尔数列的应用,不能模拟,可能超内存!

字符串,记住n=0,n=1也得考虑!

<pre class="html" name="code">#include<iostream>
#include<string>
using namespace std;
char letter[26];
double data1[26];
double data2[26];
double temp[26];
int main()
{
 int t;
 int n,i,j;
 string before,after;
 cin>>t;
 while(t--)
 {
  memset(data1,0,sizeof(data1));
  memset(data2,0,sizeof(data2));
  for(i=0;i<26;i++)
   letter[i]='a';
  cin>>before>>after>>n;
  for(i=0;i<before.size();i++)
   data1[before[i]-'a']++;
  for(i=0;i<after.size();i++)
   data2[after[i]-'a']++;
  for(i=2;i<=n;i++)
  {
   for(j=0;j<26;j++)
   {
    temp[j]=data2[j];
    data2[j]+=data1[j];
    data1[j]=temp[j];
   }
  }
  if(n==0)
   for(i=0;i<26;i++)
    data2[i]=data1[i];
   for(i=0;i<26;i++)
   {
    letter[i]+=i;
    cout<<letter[i]<<":";//
    printf("%0.lf\n",data2[i]);//<<data2[i]<<endl;
   }
   cout<<endl;
 }
 return 0;
}


 

 

                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值