Nearest Common Ancestors - POJ 1330 - LCA

140 篇文章 0 订阅
5 篇文章 0 订阅

链接:

  http://poj.org/problem?id=1330


题目:

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:

1.jpg

In the figure, each node is labeled with an integer from {1, 2,…,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,…, N. Each of the next N -1 lines contains a pair of integers that represent an edge –the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3


题意:

  给你t个样例,每个样例n个点,n-1条边,每条边给一对u v,u是v的祖先,然后最后一行u,v,让你求他们的最近公共祖先。


思路:

  十分十分裸的LCA模板题,之前瞎用快速读入结果WA了。


实现:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#define read read()
#define clr(a,b) memset(a,b,sizeof a)
int read{ int x=0;char c=getchar();while(c<'0' || c>'9')c=getchar();while(c>='0' && c<='9'){ x=x*10+c-'0';c=getchar(); }return x;}
void write(int x){ int y=10,len=1;while(y<=x)   {y*=10;len++;}while(len--){y/=10;putchar(x/y+48);x%=y;}}
using namespace std;
const int maxn = int(1e4)+7;
int dep[maxn],up[maxn][31],n,i,j;
bool vis[maxn],in[maxn],out[maxn];
vector<int> edge[maxn];
void addedge(int u, int v) {
    out[u] = in[v] = true;
    edge[u].push_back(v);
}
void init() {
    clr(vis,0);
    clr(dep,-1);
    clr(up,-1);
    clr(in,0);
    clr(out,0);
    for(int i=1 ; i<=n ; i++) edge[i].clear();
}
void dfs(int index, int d) {
    dep[index] = d;
    int len = int(edge[index].size());
    for(int i=0 ; i<len ; i++) {
        up[edge[index][i]][0] = index;
        dfs(edge[index][i],d+1);
    }
}
void process() {
    for(j=1 ; j<15 ; j++)
        for(i=1 ; i<=n ; i++)
            if(up[i][j-1]!=-1) up[i][j] = up[up[i][j-1]][j-1];
}
int lca(int u, int v) {
    for(i=1 ; i<=n ; i++) if(!in[i]) {dfs(i,1);break;}
    process();
    if(dep[u] < dep[v]) swap(u,v);
    int tmp = dep[u] - dep[v];
    for(i=0 ; i<15 ; i++)
        if(tmp & (1<<i))
            u = up[u][i];
    if(u==v) return v;
    for(i=14 ; i>=0 ; i--)
        if(up[u][i]!=up[v][i])
            u = up[u][i], v = up[v][i];
    return up[u][0];
}
int main() {
#ifndef ONLINE_JUDGE
    freopen("in.txt", "r", stdin);
#endif
    int _,u,v;
    _ = read;
    while(bool(_--)) {
        init();
        cin >> n;
        for(i=1 ; i<n ; i++) {
            u = read, v = read;
            addedge(u,v);
        }
        u = read, v = read;
        cout << lca(u,v) << '\n';
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值