Nearest Common Ancestors(LCA)

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 

 
In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y. 

Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 
 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed. 

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor. 

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

本人的第一棵LCA,虽然这道题有点简单,毕竟只询问一次,但是也大概理解了求最近公共祖先的方法

题意: 给你一棵树再给你两个节点,求他们的最近公共祖先。

题解:这算法可以直接看代码理解

下面附上AC代码

//#include"bits/stdc++.h"
//#include<unordered_map>
//#include<unordered_set>
#include<iostream>
#include<sstream>
#include<iterator>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<set>
#include<vector>
#include<bitset>
#include<climits>
#include<queue>
#include<iomanip>
#include<cmath>
#include<stack>
#include<map>
#include<ctime>
#include<new>
using namespace std;
#define LL long long
#define ULL unsigned long long
#define MT(a,b) memset(a,b,sizeof(a))
#define lson l, mid, node<<1
#define rson mid + 1, r, node<<1|1
#define Root 1, m, 1
#define Node l, r, node
const int INF  =  0x3f3f3f3f;
const int O    =  1e6;
const int mod  =  20071027;
const int maxn =  1e4 + 5;
const double PI  =  acos(-1.0);
const double E   =  2.718281828459;

int head[maxn], cnt;
struct dd {int to, next; }e[maxn << 1];
void init() { MT(head, -1); cnt =0 ;}
void add(int u, int v) {e[cnt] = {v, head[u]}; head[u]= cnt ++; }

int n, x, y;
int vis[maxn], f[maxn], in[maxn];

int find(int x) {
    return x == f[x] ? x : f[x] = find(f[x]);
}

void dfs(int u){
    for(int i=head[u]; i!=-1; i=e[i].next) {
        int v = e[i].to;
        dfs(v); // 一直深搜下去
        f[v] = u; // v子树深搜结束后,将v结合到父亲节u点上
        //这一步很关键,此操作后此时的v子树的所有点的祖先(并查集的最终点)都是u节点,可以画图理解一下
    }
    vis[u] = 1;
    if(u == x && vis[y]) {
        printf("%d\n", find(y)); return ;
        // 如果u为要查询的点x,并且y已经b遍历过了,就可以确定他们的LCA的为find(y),可以结合上面的注释理解一下
    }
    if(u == y && vis[x]) {
        printf("%d\n", find(x)); return ; // 同理
    }
}

void LCA() {
    MT(vis, 0);
    for(int i=1; i<=n; i++) f[i] = i; // 并查集
    for(int i=1; i<=n; i++)
        if(!in[i]) dfs(i); // 从树根开始dfs
}

int main(){
    int T; scanf("%d", &T);
    while( T -- ){
        scanf("%d", &n);
        MT(in, 0); init();
        for(int i=1; i<n; i++) {
            int u, v; scanf("%d%d", &u, &v);
            add(u, v); in[v] ++; // in数组记录如度,为了找到树根
        }
        scanf("%d%d", &x, &y);
        LCA();
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值